ssh backup, how to add custom port?

I’m working on setting up a backup via ssh to another server. The destination server uses a custom ssh port.

How do I enter a custom port? There’s no text box for it under Backup destinations/ssh.

Thanks for any help,


I found one post on another site saying to do ip:port, like

but that is failing, I get:

Starting backup of 3 domains to /jess_bu on SSH server (my.ip) …
Failed to connect to SSH server : sh: scp: command not found
Backup failed! See the progress output above for the reason why.

I could perhaps not have id the problem correctly, maybe this error isn’t port related?


haven’t tried it yet, but in theory, you should be able to define a destination in the .ssh/config file and use it for the backup.

hmm, not sure how to do that, looking it up to see what I can learn…

If you did man ssh_config, you could get some information about it and an example /etc/ssh/ssh_config . Although you probably would only need three or four lines)

If you need more information, then you fell free to use your FSE (favorite search engine). But you will see it is pretty straight forward.

I might have identified this problem incorrectly - looking online I found another reference saying I should be able to set the ssh port in the backup through the ssh server location, separating the ip and the port with a colon. ie:

So maybe the problem is that it’s not finding the sh: scp command, as it says…

" Failed to connect to SSH server : sh: scp: command not found Backup failed! "

but why isn’t it? and does that mean it’s not finding it on the current server or the destination server? Both are recent centos/virtualmin setups that are otherwise accepting ssh connections (on a custom port).


You could try yum install openssh-client

And maybe you could still try the ssh config option? Let’s say you have several backups (at least two for full and incremental) and you want to change the port and/or server, then it would be easier to do it in just one file.

helpmin, thank you, that worked.

So apparently I did not have scp installed? I’m surprised VM didn’t put that in or check on it during the install.

Thank you very much for your help.