SPF and PTR records - Gmail

I have in my logs the errors

Oct 28 14:56:03 3obieg postfix/pickup[1282]: C4079BB917: uid=1000 from=<threeobieg>
Oct 28 14:56:03 3obieg postfix/cleanup[5138]: C4079BB917: message-id=<qJrSksAFq9yU4EcoaGIE7Rjh2Zon0tLyEsUpyFZ8tBQ@3obieg.pl>
Oct 28 14:56:03 3obieg postfix/qmgr[1283]: C4079BB917: from=<threeobieg@3obieg.pl>, size=1069, nrcpt=1 (queue active)
Oct 28 14:56:04 3obieg postfix/smtp[5139]: C4079BB917: host gmail-smtp-in.l.google.com[74.125.131.26] said: 421-4.7.0 This message does not pass authentication checks (SPF and DKIM both do 421-4.7.0 not pass). SPF check for [3obieg.pl] does not pass with ip: 421-4.7.0 [135.181.98.166].To best protect our users from spam, the message has 421-4.7.0 been blocked. Please visit 421-4.7.0  https://support.google.com/mail/answer/81126#authentication for more 421 4.7.0 information. k3-20020ac24f03000000b004b0012d66casi2725982lfr.276 - gsmtp (in reply to end of DATA command)
Oct 28 14:56:04 3obieg postfix/smtp[5139]: C4079BB917: to=<qqq@gmail.com>, relay=gmail-smtp-in.l.google.com[2a00:1450:4010:c0b::1b]:25, delay=0.76, delays=0.01/0/0.52/0.24, dsn=5.7.1, status=bounced (host gmail-smtp-in.l.google.com[2a00:1450:4010:c0b::1b] said: 550-5.7.1 [2a01:4f9:c010:d50::1] Our system has detected that this message does 550-5.7.1 not meet IPv6 sending guidelines regarding PTR records and 550-5.7.1 authentication. Please review 550-5.7.1  https://support.google.com/mail/?p=IPv6AuthError for more information 550 5.7.1 . b23-20020a0565120b9700b0049f53b6605csi3167394lfv.608 - gsmtp (in reply to end of DATA command))
Oct 28 14:56:04 3obieg postfix/bounce[5202]: C4079BB917: sender non-delivery notification: 8BE3FBB918
Oct 28 14:56:04 3obieg postfix/qmgr[1283]: C4079BB917: removed

The current configuration is:

In Virtualmin I have a configuration of

TLSA records enabled: Yes
DMARC record enabled: Yes
DNSSEC signature enabled: Yes

Mail is not reaching any recipients, not just those from Gmail. Where should I start to fix the errors?

I use https://mxtoolbox.com/ to fix dns issue, one thing I spotted the SPF records don’t match your screenshot, its shows v=spf1 include:_spf.cloudsender.pl ~all
Are you using another dns server? Also ns don’t match