Spamhaus test fail, how do I fix

I just tested to see if spamhaus if configured out of the box on virtualmin.
Seems like its not, is there good instruction somewhere to configure it?
Test site.


Add it to your SpamAssassin configuration. That allows you to choose a weight for how important a spamhaus hit is (vs. setting it up in Postfix, which is always a yes/no decision).

Is there a How To url on how I do that. When I edit spamassassin config files only see
Do add something in there?

The Spamhaus folks provide documentation. I assume they know how to do it: Data Query Service using SpamAssassin — Spamhaus Technology Documentation 2.0 documentation

:frowning: I saw that page, thought there was a simple solution.


It’s got a lot of steps to enable all the options, but it seems pretty simple. You’re just copying a bunch of SpamAssassin plugins into place and then enabling them.

SpamAssassin ships with several DNS blacklists in the stock package, as well, if you just want that sort of thing, rather than Spamhaus, specifically. Docs for that are here: DnsBlocklistsInclusionPolicy - SPAMASSASSIN - Apache Software Foundation

We don’t enable any by default, as they are potentially problematic, often require some sort of account to be able to access them, may have licensing issues (e.g. spamhaus is not free for commercial use).

If you want to do anything fancy with spam management, learning your way around SpamAssassin is perhaps the most valuable thing you can do. It is large (because the spam problem is large), but most of the time configuring SA is just a matter of turning plugins on or off and giving them a score. Spamhaus is only slightly more complicated because the plugins don’t ship as part of SpamAssassin, likely due to the licensing issues.

Thanks, I’ll have a look at the alternatives.


In the webmin spamassassin mail filter, I was only able to see And no rules. I changed to

I now see all rules, is this ok?


You should never modify files in /usr/share. They will be overwritten by package updates.

You should add the rules you want in /etc/mail/spamassassin. is fine for those rules.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.