spamassassin running but not tagging messages as spam

I currently have Virtualmin 1.5 running on CentOS 5.4, configured for postfix. Spamd is in fact running, and mailbox_command is set to “mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME”, but I do not see spamd in /var/log/maillog or anywhere else. Spam & virus scanning is enabled, but it doesn’t look like it is tagging any messages as spam, even on a gtube test.


If you look at the headers of the email, are you seeing any X-Spam-* headers in there?

Also, there’s a few places where Spam Processing would need to be enabled.

You’d need that setup in System Settings -> Features and Plugins, for one.

In Edit Virtual Server -> Enabled features, you can verify that it’s enabled for that particular Virtual Server.

And also, in Server Configuration -> Spam and Virus Delivery, you can tweak various settings related to spam processing.


Thanks for your help, but it’s enabled in all three places.

…and no, there are no X-SPAM flags in the header of any emails.


Just for fun, what happens if you restart SpamAssassin (/etc/init.d/spamassassin restart)?

Do you see any errors in /var/log/maillog?

Now go ahead and send yourself an email – do you see errors regarding SA timeouts, or other problems?


No errors in the logs. Spamassassin just restarts as normal during a restart – no errors.

I actually did notice a setting under Email Messages > Spam and Virus Scanning

I changed spamc to spamassassin, and now it works! What are the benefits/disadvantages to this, and why isn’t it working when set to spamc?

Thanks for your help!

Why isn’t it working with spamc? ATM, I have no idea :slight_smile:

However, using SpamAssassin (standalone) means that SA runs as a daemon, rather than spawning an entire new SA process each time an email comes in. It’s remarkably more efficient, at a cost of a little more RAM.

I’d personally recommend that on any setup where RAM isn’t significantly constrained.


Ok, great. I’m not too much in need of ram, so I would probably even prefer the standalone over spamc.

Thanks for your help – I’ll try to diagnose the spamc issue if I ever decide to move back, but for now I think the standalone version will work better.

Yeah, using the standalong SA server is one of the first things I enable on any server I setup – I think that’s a good option since you have some available RAM.

But yeah, if you do figure out the spamc issue, by all means let us know, as that should work :slight_smile: You might also take a peek in the /var/log/procmail.log file, perhaps some errors are showing up in there.


This fixed my issue, Thanks

This was on a fresh install of Virtualmin Pro on Centos 7 for migration from Centos 6.6. The migration has been slow going.

I was pulling my hair out searching google until I searched with the correct phrase which was;
virtualmin spamassassin not working

Second result was; spamassassin running but not tagging … - Virtualmin

I’m glad to know that given enough ram, it’s the best option.