SpamAssassin "RDNS_NONE" error but there is a RDNS properly configured

SYSTEM INFORMATION
OS type and version Debian 10
Webmin version 1.994
Virtualmin version 7.1-1
Related packages SUGGESTED

Hello all,
I have some issues with SpamAssassin it is showing > Delivered to internal network by a host with no rDNS

This may indicate you do not have a rDNS configured for your hostname or the rDNS does not match your sending IP

But I already have rDNS properly configured.



Check the headers in the email for the ips its using, just make sure its correct. Maybe its a local ip seeing its internal mail. Like
Received: from smtp.example.com (localhost [127.0.0.1])

@stefan1959

Thank you for your reply.

I sent a test mail to my Gmail account and this is what I see.

Delivered-To: mygmail@gmail.com
Received: by 2002:adf:a2cb:0:0:0:0:0 with SMTP id t11csp88466wra;
Thu, 4 Aug 2022 01:29:23 -0700 (PDT)
X-Google-Smtp-Source: AA6agR6C5v4FqIYma1YVp++qvSel9+pDi3+XIe6qDx9xK5m9MmlAolgnLelSae2f0uWW4jwQWu3j
X-Received: by 2002:a05:6512:3f05:b0:48a:ca44:80f2 with SMTP id y5-20020a0565123f0500b0048aca4480f2mr336154lfa.224.1659601763444;
Thu, 04 Aug 2022 01:29:23 -0700 (PDT)
ARC-Seal: i=1; a=rsa-sha256; t=1659601763; cv=none;
d=google.com; s=arc-20160816;
b=pCD3GIoA5/KfI7BPCXCNdEoa8rIbLr3a2Op5iT68V2w3VBXWGmC+lrdIol8jFGxEJX
qIudcgw+MNEE/rcRbRIDwGZVg5XY3QIrm5f6JVvhDoHQgcrOxROTGJ/oLMaotFJwje5X
/QZnn5xy4s5824HYhFXxiciQIjb8Qq5zG7EKq7OOwvjgdy/WQnJQz6AMBYnpofeLqQn8
r7jYfZHNB+7Nf9i8QjA8+Qpiua5qocPE+n6bMI976KM6rDc9DP8tiGAtKZtG83ssFIUR
kj3kNjDg9EOVJWW4cfXySFEJiHfZfXser/2yWh9kaH0SToIHHXiT7bcUFCnfd/7Y6x+6
tiJQ==
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com; s=arc-20160816;
h=content-transfer-encoding:message-id:subject:to:from:date
:mime-version:dkim-signature;
bh=zoPeF4ezZORxXKwuU5JzkuwNlup9ouMZiltczKD8eLY=;
b=vSqZBdufsPbtoD7InFaItmkuM+Vvsh3+s9HYUOp6OA1VJ2O2Fb+M+a5GLmoSOHvJKi
yEUqhynnY1shS/UphGlYNyG3+Ug/eeKsXWSBVnSmhwoF6T91AHS2aXCBCBGVtiv9P9Af
qUilu7B0ziP2DNSHiCo0bsdxAhgZjZzr68wDZsGX2rWEmeLxyNmVtjsdd5U3ril2Cdnd
haCw3CdFJIBHYXGZ1FfveB+WqTbsoQuqzo6xhmFbx8eOHGaZ5gS3vMIbrPFIC1bf2asT
PITXQ2iLNA2uD6vOSv7mlqW+ErRSYlsvQBorh0b2j/LrgGUi+VoFRmvK8WzhQaHjLgcN
A/Bg==
ARC-Authentication-Results: i=1; mx.google.com;
dkim=pass header.i=@mydomain.net header.s=202109 header.b=PMargNDy;
spf=pass (google.com: domain of admin@mydomain.net designates xxx.xxx.x.3 as permitted sender) smtp.mailfrom=admin@mydomain.net;
dmarc=pass (p=REJECT sp=REJECT dis=NONE) header.from=mydomain.net
Return-Path: <admin@mydomain.net>
Received: from mydomain.net ([xxx.xxx.x.3])
by mx.google.com with ESMTPS id e20-20020a2ea554000000b0025e293efae6si218908ljn.329.2022.08.04.01.29.23
for **mygmail**@gmail.com
(version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256);
Thu, 04 Aug 2022 01:29:23 -0700 (PDT)
Received-SPF: pass (google.com: domain of admin@mydomain.net designates xxx.xxx.x.3 as permitted sender) client-ip=xxx.xxx.x.3;
Authentication-Results: mx.google.com;
dkim=pass header.i=@mydomain.net header.s=202109 header.b=PMargNDy;
spf=pass (google.com: domain of admin@mydomain.net designates xxx.xxx.x.3 as permitted sender) smtp.mailfrom=admin@mydomain.net;
dmarc=pass (p=REJECT sp=REJECT dis=NONE) header.from=mydomain.net
Received: from mydomain.net (localhost [IPv6:::1]) by mydomain.net (Postfix) with ESMTPA id 689831FD19 for **mygmail**@gmail.com; Thu,
4 Aug 2022 11:29:21 +0300 (EEST)
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=mydomain.net; s=202109; t=1659601761; bh=zoPeF4ezZORxXKwuU5JzkuwNlup9ouMZiltczKD8eLY=; h=Date:From:To:Subject:From; b=PMargNDyIdk983GBTaDVwAvlvSdG9vPrlW/RHjHr05J6EzY7jN/hrowjbyduWOa/h
8ZsjPap4qx5C+gGBjdOLNE81UdZhbbOdKUG/Vh2/UjgQNlT77VwJulZpR3DQz9bYwi
V9krfCWCiB3NKnqNOkB47sfoerj0HoxmCjGjJi7DcxrBz+i07dIyNqRJy4m8QloS+n
YYuKa67fWv6WpJ3CaiJqFvlH0IYoJPZMFwoGaXj6+AtBC8MxprfQsuWcRrs+ykbH1x
DA9eZI2kFOqh3SeeKVh8nLLDRofCW5wAGM/gra4/dNntcMMOdrjhzFlbTYSpK0Kv3c
Vv2rex1EbhWhg==
MIME-Version: 1.0
Date: Thu, 04 Aug 2022 12:29:21 +0400
From: “admin-mydomain.net” <admin@mydomain.net>
To: mygmail@gmail.com
Subject: Hello
Message-ID: <359bbc043aa5107cda2e3427b5aab5e9@mydomain.net>
X-Sender: admin@mydomain.net
Content-Type: text/plain; charset=US-ASCII; format=flowed
Content-Transfer-Encoding: 7bit

That looks like a issue, localhost.
You might have a issue in your host file settings.

Hello @stefan1959

This is what my hosts file looks like. etc/hosts

127.0.0.1 localhost

The following lines are desirable for IPv6 capable hosts

::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
xxx.xxx.x.3 mydomains.net mydomain

I have no experience with IP6 (avoiding it a present)
This is my host

I had IPV6 line in my setting so i deleted all and disabled IPV6 now the settings looks like this

Let me try to test again by sending an email to my gamil and also check the mail-tester.com

really not sure why your getting localhost with ip6 address in there.
Bigger brains then me might know, google is my brain right now :slight_smile:

1 Like

Hopefully, someone with more experience will be here soon :slight_smile:

Thank you @stefan1959 for trying to help me.

Just a thought, check Postfix settings, the general setting has some stuff regarding sending hostname.

P.S. in shell when you type hostname does that echo your domain name(what your using for reverse)?

rdns is not configured in webmin/virtualmin, but by your provider or his provider, whoever is resposible for the ip range at RIPE (if your in europe) in the reverse dns server that is entered at RIPE by your provider. You can find it via the commandline via

dig -x 8.8.8.8

this gives


;; ANSWER SECTION:
8.8.8.8.in-addr.arpa. 21599 IN PTR google-public-dns-a.google.com.

Best is to look it up on another server or with a tools like Reverse IP Lookup - MxToolbox

Disabling ipv6 you do at Networking - Network Configuration - Network Interfaces – and then your network interface you want to change

regards
Jan

1 Like

@Linulex Hello thank you for your reply. I checked the “dig” command and this is what I got from the result.

Screen Shot 2022-08-04 at 6.09.25 PM

did you do this on an external, independant server? 127.0.0.1 does not seem correct to me. What result does mxtoolbox give?

Hello,

I’m using a VPS server. this is what I get in mxtoolbox

From what i can see is your ip address where you send mail from different then your domainname. 1 has reverse dns, but the other not.

1 Like

If you wonder where i got your domainname from: from you. its in the screenshot in Post #3 under your headers in green:

regards
Jan

1 Like

Hello @Linulex

Oh wow, all these censored IPs and Domain names you have managed to find out my real IP and Domain :sweat_smile: I guess I didn’t censor enough or you are a network expert.

Can you please advise me on how can I troubleshoot these issues or where to look into them? I checked my Cloudflare and it has the correct DNS.

not a network expert, but able to read: as i sayd you posted it your self in the screenshot.

You need to adjust the reverse dns of so that it points to or better whatever name you gave the server. Your upstream provider chould be able to help you with that.

Regards
Jan

1 Like

@Linulex
Exactly, I have missed censoring that part :grimacing: so many details in that so It got really messy and I missed one part.

BTW if it is possible will you be kind enough to censor my IP and domain this will help me in the long run cuz I don’t want to get attacked by spammers :frowning: if you think it is too late to censor then I can understand.

I will contact my ISP and have a word with them to see to solve this issue.

Just want to say thank you so much for pointing out where is the issue I’m having.

Okay I just turn off the orange button in Cloudflare and now in Intodns result I can see the correct IP

Screen Shot 2022-08-04 at 8.34.37 PM

Edit:

What a surprise now I have 10/10 mail-tester score