Spamassassin auto_whitelist

I’ve just discovered that the my VMPro server is not using auto_whitelists for my users. This box was a clean CentOS 5 install and the VMPro install script.

When I click on the button to "Manage Auto-Whitelists" in the SPAMAssassin module and select a user in one of my virtual domains, I get a "The user -user name here- does not have an auto-whitelist file." SPAMAssassin otherwise works well on this system for all addresses.

I’ve done the forum search and google search and not found any info that I’m able to use to fix this. I checked both the and files and cannot find anything shutting off auto_whitelists. And I haven’t been able to find any options to activate autowhitelists in VMPro.

Any help pointing me in the right directions would be welcome.



Check under "Miscellaneous Privileged Options" that Automatic whitelist file path is set properly… It should probably be "default".

Also, my users had old .whitelist files in their home directories that were not compatible with the current version.

All of my domains had been migrated from a previous VM server that was configured differently. I changed the path to the default and deleted all of the old whitelist files and everything works fine now.

Steve<br><br>Post edited by: SteveAcup, at: 2008/11/08 17:22