SPAM & Virus filtering off by default?

I have just done a fresh install of Fedora Core 6 and Virtualmin.

I noticed that:

  • Per-server SpamAssassin mail filtering
  • Per-server ClamAV virus filtering

are not turned on by default at Module Config.


QUESTION 1: I think I remember that it used to be enabled by default? Is there any reason why they are now switched off by default?


When I turned them on at Module Config and recheck config, I get the following error messages:

"SpamAssassin and Procmail are installed. However, your mail server does not appear to be configured to deliver using Procmail.

SpamAssassin is configured to be run from the global Procmail configuration /etc/procmailrc, which is not needed as Virtualmin will set it up on a per-domain basis.

… your system is not ready for use by Virtualmin."


QUESTION 2: What do I need to do to get them working?


Many thanks in advance.

Problem solved (Customer Issue Ticket #379). Thanks Jamie.


The spam and virus filtering features have always been turned off by default, but now that we include all the dependencies required for this as part of Virtualmin Pro, I can’t see any good reason for this. So in future releases, they will be enabled by default.

Regarding the problems you saw when checking the module config, there are two things you need to do to fix them :

  1. If using Postfix as your mail server, make sure that in the /etc/postfix/ file, the mailbox_command line is set to :

mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME

What is surprising is that this should have been set by default when installing Virtualmin. Did you get any errors from the install script?

  1. Because spam filtering is enabled domain-by-domain, you don’t need to have any directives in /etc/procmailrc to call spamassassin. The quickest way to fix this is just to delete /etc/procmailrc, and Virtualmin will re-create it when spam filtering is enabled for a domain.