Spam not delivered to spam folder

hi there,

i’ve done a quick search on the forums but did not find a response to this problem.

well, to put it short, incoming spam is marked as spam by spamassasin, but still delivered to inbox although the domain is set up to “Write to mail file under home directory ~/Maildir/.Junk/” under “Spam and Virus Delivery”.

for example, I do get the “Spam detection software, running on the system , has
identified this incoming email as possible spam. The original message
has been attached to this so you can view it (if it isn’t spam) or label
similar future email.” message on a 24.8 points message so it is obvious this is caught by spamassasin, but still those mails get into my inbox.

what can be done?

thanks much.


I’m curious, if you instead temporarily set that to use “Write to standard spam Maildir ~/Maildir/.spam/” – do those emails end up in your .spam folder?


andreychek, thanks for your help.

i’ve tried playing around the two options: “Write to standard spam Maildir ~/Maildir/.spam/” and “Write to mail file under home directory directory”. this is what i’ve found:

  1. set the option to “Write to standard spam Maildir ~/Maildir/.spam/”;
    result: spam was successfully moved to ~/Maildir/.spam/

  2. set the option back to “Write to mail file under home directory ~/Maildir/.Junk/”;
    result: again, spam was delivered to INBOX

  3. set the option to “Write to mail file under home directory ~/Maildir/.spam/” (this should have the same effect as “Write to standard spam Maildir ~/Maildir/.spam/”;
    result: spam was delivered to INBOX!

from my findings, it seems that the “Write to mail file under home directory directory” doesn’t work at all, at least for my setup.

i also want to mention that the .Junk folder and its subfolders does exist, and it has the appropriate owners and permissions set. actually, thunderbird DOES use this folder because i’ve set it to trust spam headers set by spamassassin and move them to Junk folder. the problem comes when i use webmail and the messages aren’t moved by the sistem like it should.

It sounds like you may be seeing a bug of some sort. You may want to file a bug report for that using the Support link above. Then, Jamie can work with you to get that sorted out.

I suspect most folks keep that setting at the default, so if there’s a problem with it, you may be one of the few who noticed it :slight_smile:


I also have this problem.

“Write to mail file under home directory” is “~ / Maildir / .Junk /” not working

IN Roundcube config
// to modify
$rcmail_config[‘junk_mbox’] = ‘spam’;

The Roundcube will automatically switch destination SPAM folder “Junk” to “spam”