.spam folder

Dear all, bonsoir !

I have another question :

Is it possible to change the destination folder of spam ?
I think now it is in ~/Maildir/.spam/ but :

I would like spam to go in a “junk” folder located in an “INBOX” folder (my IMAP directory) , because I use Mail.app from Apple and it stores spam in a “junk” folder that it auto-creates, and then I can’t see or access the real spam folder only via webmail…!!!

Am I clear ? I am afraid not…

Anyway thank you for wasting time to read…

Howdy,

You can set what folder spam goes to by going into Server Configuration -> Spam and Virus Delivery, and changing “Destination for spam emails” to your desired spam folder.

-Eric

I checked the “Write to mail file under home directory” option

and put this in the field :

~/Maildir/.INBOX.Junk/

Does that sound correct to you, Eric ?

Did I make a big mistake ?

Thank you !

Yup, that sounds good – the next step would be to keep an eye on it and see if you get any mail in that folder.

Eric,

I am not quite sure it’s working… I receive tons of spam everyday and today : nothing.
I just removed the / at the end of the

~/Maildir/.INBOX.Junk/

line, it now reads

~/Maildir/.INBOX.Junk

Any advice ? I don’t really get the meaning of the help page :

“Write to mail file under home directory”
Spam is saved to the mail file under the user’s home directory that you enter.
To write to a Maildir format directory, put a / at the end of the filename.

That is what made me think of removing the /

More over, I found two spam e-mails in the INBOX folder displaying :

Spam detection software, running on the system “ns383392.ovh.net”, has
identified this incoming email as possible spam. The original message
has been attached to this so you can view it (if it isn’t spam) or label
similar future email. If you have any questions, see
the administrator of that system for details.

Content preview: INTUIT INTUIT To Whom It May Concern […]

Content analysis details: (22.0 points, 5.0 required)

pts rule name description

(…)

I am wondering why they don’t look like regular mails, without any comment included in the body of message ?

Thank you for your time and patience …

Bonne journée !

Howdy,

If the path ends with a “/” character, it will be treated like a directory (which is Maildir style).

If it doesn’t end with a “/”, it will be treated like a file (which is mbox style).

I would recommend using the “/” with Maildir style – that’s how your system is configured to handle email.

If you don’t think it’s working, you could always take a look at your email logs to try and figure out where the email is going. You can use the procmail log in /var/log/procmail.log to see where email is being delivered.

What you can do there is look for email being delivered to your user, and then see if you’re getting any errors for spam email.

-Eric

Thank you for this brilliant help, very much appreciated.

Merci !

I know this is an old thread, but I just when through this setup. I think this will help others who use Apple Mail as their mail client and would like to configure their mail server appropriately.

As per Eric’ instructions I went to “Server Configurations > Spam and Virus Delivery” and under “Write to mail file under home directory” I entered:

~/Maildir/.Junk/

That wasn’t working. After reviewing the procmail.log file, I saw the following error:

procmail: Unable to treat as directory “/home//homes//~/Maildir/.Junk”
procmail: Error while writing to “/home//homes//~/Maildir/.Junk”

Based on the above error, the correct setting is:

Maildir/.Junk/