Sometimes cannot connect via FTP


I log into one of my Virtualmin sites every week on Sunday to perform a backup of a website.

Sometimes I am unable to log in via FTP, I use FileZilla and it shows an error message such as this:

Response: 530 Login incorrect.

Error: Critical error

Error: Could not connect to server

However, if I SSH into the server and restart the Proftpd service, I am then able to log in.

I use a $5 a month server from Digital Ocean, this comes with 512mb RAM but I have setup a 4GB swap file.

I don’t understand if Proftpd is running out of memory or if this is another issue.

I have attached a screenshot showing memory and the swapfile before I restarted the Proftpd service.

My Virtualmin version is 4.16, and Webmin version 1.740 running on Ubuntu Server 14.04.1 64-Bit.

Any help is greatly appreciated.


EDIT: Attachment didn’t seem to upload. It can be viewed here:


Hmm, it’s possible that you’re running out of memory. You may want to run the command “dmesg | tail -50”, and see if you see any Out of Memory (OOM) related errors.

Also, you may want to look at the “ps auxw” list, and see if proftpd is running still.


Hi Eric,

Thanks for your help. I’m going to try those commands when the FTP stops working again. I’ll try and post what I see from the command.

If this doesn’t turn up any results, I suppose I could make a quick cronjob to restart the service.


Recommended memory for almost any control panel is min 1GB and if you think to have low to medium traffic CMS site then at least 2GB. VPS with 512MB of memory is good for testing or if you think to deal with everything manually but not to have control panel.
Other solution you could try is to turn off all services and use them externally, instead of bind use dns from you domain provider or cloudflare, instead of postfix use external email like zoho with 5 free users/emails (alternative to google apps), then if you turn off your email you dont need anymore spam and virus protection so turn off spamassassin and clamav including usermin… and so on. Then maybe you will have a little more memory to run everything.