Something wrong with initial DNS on new Virtualmin Setup

All I’m trying to do is get Virtualmin setup on a new OS. So that’s what I’ve done. Here are the fact that I believe are important when starting to install…

  • pfSense assigns a fixed IP to the network adapter on this new server automatically based on MAC Address.
  • Server network interface is set to DHCP.
  • Install Ubuntu Server 18.04 LTS from USB key with OpenSSH so I can work from laptop.
  • I run the Virtualmin script URL on my license.
  • Virtualmin installs and I can access at https://localip:10000
  • I run through the post installation wizard and I’m stuck at DNS Configuration

Primary nameserver cannot be resolved from the rest of the Internet: Unknown response:

  • pfSense NAT set to forward 53 to this server. I confirm open port from the internet.

  • I can ping my external IP (static) from inside the network.

  • I can ping all other systems on the subnet.

  • I can ping myself on the server.

  • If I try to access http://:10000, I see a login page, but am unable to login to webmin that way.

  • If I attempt to use an external name server lookup like the DNX lookup at mxtools, I get:

Loop detected! We were referred back to '<externalipaddress>' and I don’t know what that means.

Question: Isn’t there supposed to be some evidence of my name server’s FQDN in BIND somewhere, or is that the step that I’m stuck on?

I can’t figure out why I can’t get past this step.


I went ahead and added a virtual server to the setup which is the same domain as the name server and it created DNS records and suddenly DNS tools could see the name server and resolution happens…but:

It also added my internal IP address as a an A record, publishing it to the world.

But this all seems to be strange, backwards behavior. The hostname of the server was set upon running the initial setup script as The last time I remember installing Virtualmin, the start of authority for the name server’s hostname domain was automatically setup and moving through the post installation wizard was a breeze.


so you have registered your nameserver glue records with your domain registrar yes?

to check this you should be able to, using mxtoolbox, lookup the A record for and

which i imagine in this case would both be the same ipaddress as your isp assigned home/office static ipaddress.

both ns1 and ns2 would also be virtual servers on your virtualmin system.

Yeah, the problem stemmed from the authority not being written to anything DNS upon installation of Virtualmin. It wasn’t until I added the first virtual server that the rest of the world could see the system. I’ve had this setup on another system for a few years, but recently had a pretty hefty disaster…so… ;).

i understand. so its all working now?

I dont actually use this method myself…i use domain registrars dns hosting (pointing an a record for each domain at my vps) rather than my own nameservers. It has its drawbacks of course (ie if i ever wanted to change server ip address), however, it allows me to just focus on my own system administration without bothering bind dns as well.

I have my hands full getting my head around the vps administration and email for now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.