Something is crashing Virtualmin/Webmin

I’m not sure what’s going on here. I’ve had Virtualmin/webmin installed on my site for MONTHS without any difficulties whatsoever. Suddenly this afternoon I tried to access virtualmin and got this message:

Unable to connect

Firefox can’t establish a connection to the server at

I actually rebooted the server, which fixed the problem temporarily, but eventually the message came back.

On sunday the site went “live” (it’s been up for months, but it wasn’t until Sunday that I pointed my domains at it). Could virtualmin have “died” from lack of resources? How do I restart it? How can I troubleshoot this?

Hey Christopher,

Yeah, I’d suspect the OOM (out of memory) killer is knocking out the Webmin process. If this is a Virtuozzo VPS system, it’ll pretty much just randomly kill things on occasion (it’s a bug in the vservers and vz codebase…not sure when they’ll fix it, but it’s been around for over a year). Even if it isn’t, memory could be the problem.

Take a look at swap usage…if it’s relatively high (like more than a few MB), you might need to follow the Virtualmin on low memory systems guide found here, to reduce usage:,virtualmin_on_low_memory_systems/

Following all of those steps will reduce memory usage by 200+MB. Virtualmin’s Webmin process is usually not the largest process (or even in the top three), but it’s the easiest to reduce and by a quite large amount (stock Webmin on a Virtualmin system runs at about 95MB…after disabling pre-caching, it’s only about 10MB).

You can check the /var/log/messages for OOM related errors to confirm whether memory is the source of your troubles. You’ll also probably see Postfix dying due to memory allocation errors (but it has a tiny master process that usually manages to spawn new ones later so it never really disappears, but the errors will litter your messages or maillog).

Hm. Your post just reminded me of something that’s probably important and probably has nothing to do with Virtualmin at all…

I’m currently using Slicehost ( as my provider, and I upgraded my slice to one with more memory (I went from a 512 to a 1024) – in the process it seems to have done something to screw up Virtualmin’s settings, because all of a sudden the Virtualmin system information page no longer displays the virtual memory or disk space bars.

And apparently it also can’t find the mount point for “/home” which means that it can no longer assign disk quotas to virtual domains.

So the transfer from one account to another was not the painless process it originally appeared to be, and I bet the lack of virtual memory is probably something I want to fix quick.

… I don’t suppose Virtualmin has a tool that can reset all that, does it?

The problem is that when my server was upgrade the UUID changed, and fstab is still listing the old ones. Is there a way to use virtualmin to report the correct UUIDs so I can update fstab accordingly?

Hey Christopher,

This would be a job for Webmin, but since it gets its information from fstab and mtab, there isn’t much it can do if those things are wrong. :wink:

This can only happen in VPS type systems, where the mounts happen outside of the control of the guest OS. You can probably pull the necessary details out of the mount command (run it with no options, and it should list all mounted filesystems…but it may be pulling from mtab, as well!).

Hi Joe,
Just went in to my server and got same problem as Mike in 5942. Again. No access to Vmin , but Server is accessible publicly and Webmin.
This has happened twice before I think now. I’d like to find out why soon as I will soon need a REAL working Server :slight_smile:


EDITED: I looked up the last two "events" and this was your advice then:
/etc/init.d/webmin start
I just dug it up and "putty-ed" in and it worked.
Big question still is: why is it happening -again?
(You might recall this Server really does no work at all)

Post edited by: JohnRigby, at: 2007/07/08 01:10

Catching up on my reading - “Announcements” I see that an upgrade just went thru - wondering if my “events” aren’t something to do with your system upgrades???
Himagain<br><br>Post edited by: JohnRigby, at: 2007/07/08 01:23

Howdy John,

As in Mike’s case, I’d first suspect low memory. Check /var/log/messages for OOM related error messages. That’s the only consistent cause of Webmin shutdowns that I’ve seen.

Urgh…Why reply to Christopher’s thread to talk about a different issue? Now we’re all just confused. :wink:

Mike’s problem is different from this one. In this thread, the cause of the problem was obviously memory allocation errors (probably a bug in the VPS kernel running on Christopher’s box…it’s a well-known problem on vservers and virtuozzo systems). I’ll follow up on Mike’s thread with the solution to his problem (which is also not the same as the one you describe which seems likely to be memory allocation errors).

Urgh…Why reply to Christopher’s thread to talk about a different issue? Now we’re all just confused. :wink:

Hi Joe,
Sorry - was just trying to contribute - to me it WAS the same thing. Vmin simply vanishing. Not likely to be a memory problem in my case - the Server does no work, but will go check.