[SOLVED] Unable to login to remote FTP server


I have a server set up as a backup server with Virtualmin/Webmin installed.
I have several cPanel servers which send their backups to this backup server.
Each cPanel server has its own virtual server on this backup server.
This used to work perfectly fine, no problems at all.
Until I now found out that no more backups are being made.

In the cPanel backup logs I find this:
Net::FTP=GLOB(0x208b5f8)<<< 220 FTP Server ready.
Net::FTP=GLOB(0x208b5f8)>>> USER xxxxxx
Net::FTP=GLOB(0x208b5f8)<<< 331 Password required for xxxxxx
Net::FTP=GLOB(0x208b5f8)>>> PASS …
Net::FTP=GLOB(0x208b5f8)<<< 530 Login incorrect.
Net::FTP=GLOB(0x208b5f8)>>> QUIT
Net::FTP=GLOB(0x208b5f8)<<< 221 Goodbye.
[cpbackup] Unable to login to remote FTP server.

I have checked and double checked, the login details ARE correct. Nothing has changed, it just quit working at some point.
I have restarted ProFTPD on the backup server, but that didn’t help either. I did read about problems with earlier Webmin versions, but I updated it to the latest 1.600 version and it’s still the same (OS is CentOS 6.3).

Any idea what might be going on here?


Do you see any errors in the logs of that FTP server?

And, are you able to login manually, using an FTP client on your desktop?

It almost sounds like the FTP password may be incorrect… is it possible the password could have changed, or the FTP account disabled?


I had a similar issue with email logins a while ago. It turned out that the “saslauthd” service made a boo-boo and needed to be restarted.

I’m not sure if the same authentication daemon is used for FTP as well, but since both FTP and mail rely on Linux user authentication, it is possible.

You might want to try restarting the auth daemon (depending on your distro e.g. with “service saslauthd restart”) and see if FTP login works again then. If not, please check the logs. :slight_smile: (/var/log/syslog and /var/log/auth.log for starters)

The login/password is most definitely correct.
It never changed, and just to make sure I reset it in Virtualmin again.
And no, I can’t access it via an FTP client either, same problem occurs.
Yet when backing up files via rsync/SSH (via the CPremote cPanel plugin), then it works fine.
I tried restarting the saslauthd service, that didn’t make any difference either.
What’s more, /var/log/proftpd is empty, there are no files there whatsoever.
I also do not have the logs /var/log/syslog nor /var/log/auth.log, they do not exist.

Just wanted to update this post, as I found the solution.
The installed proftpd version was from the rpmforge repo.
I removed proftpd, disabled the rpmforge repo and reinstalled proftpd from the CentOS repo instead.
All working fine now!

Thank you Patrick70! I have reinstalled proftpd also (1.34 was, 1.33 now) and now ftp logins are working…

Glad to hear it, ulrith :slight_smile:

Hi would you mind posting the steps to do this? I have the same issue with a new ftp user, authentication failed when all was entered correctly.