[SOLVED] SSL Certificate Binding


I have webmin and virtualmin running on cpanel.manjot.net . I have a virtual server in virtualmin for manjot.net and when I enable ssl for manjot.net. The certificate for cpanel.manjot.net return with the certificate of manjot.net virtual server, instead of certificate I set in webmin but working fine when accessing via ip address


Operating system: Ubuntu
OS version: 20.04.1 LTS

Is cpanel.manjot.net an alias of manjot.net?

And, you shouldn’t mess around with the Webmin SSL configuration. Just let Virtualmin handle it. When you create a Virtualmin domain and setup an SSL certificate for it, Webmin will automatically serve that certificate when connecting to Webmin on that domain (Usermin likewise).

Manjot paa ji,

Please see these recent discussions which are related to the issue you mention:

I always create a virtual server with the same domain name I use as hostname - (e.g. vps01.indiax.com), apply SSL to it (mostly via Let’s Encrypt) and then use the “Copy to Webmin” etc. group of buttons to apply that SSL to ports 10000, 20000, Postfix, Dovecot at al.

I would be happy to help you in any way I can, bro! Your community is doing a great service to the nation.

#IamWithFarmers, #KisanEktaZindabaad

@Joe @calport I replaced the certificate on manjot.net virtual server with cpanel subdomain in it. All Solved.

I have no idea what that means, but I’m happy you got it sorted.

@Joe I replaced the certificate that was on the manjot.net site in virtualmin with cpanel.manjot.net hostname in it.

1 Like

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.