[SOLVED] Postgrey auto whitelist

I started using Postgrey today and have some question please.
Simple install using Virtualmin.

In /var/log/mail.log I see:
postgrey[17450]: action=pass, reason=client whitelist, client_name=mail-ig0-f174.google.com, client_address=, sender=someuser@gmail.com, recipient=someuser@mydomain.com

/etc/postgrey/whitelist_clients is empty
I also cleared Postgrey’s db and did a service restart.

Somehow, Postgrey whitelists some domains, like google.com and I have no clue why.
Any hints as to why it does that?

Also, changing the default text Postgrey responds with, does not work for me.
Any hints how to change it?

Thank you.

Howdy – I’m glad you got it working, thanks for letting us know how you fixed it!


Found the problem.

Postgrey on Ubuntu 12.04 is a bit…buggy to get started.
First off, the service does not shutdown, meaning "service postgrey stop"does not actually kill the pid.
Thus, any modifications I made, including the whitelist were not active because postgrey was not reloading the configuration.

For others that might have this problem.
After you install Postgrey and you are able to start it, do a:

  1. service postgrey stop.
  2. ps -ef|grep postgrey
    Most likely, you will see the PID is still active.
  3. Edit /etc/init.d/postgrey
    At the top of file, after DAEMON=/usr/sbin/postgrey add a new line:

For Start, Stop, Reload, Status, modify:
Instead of --name $NAME make it --name $PROCNAME
Pay attention to “”
4. Kill the Postgrey pid and do: service postgrey start
Check the process is running: ps -ef|grep postgrey
Stop the service: service postgrey stop
Check again to make sure the pid is not running: ps -ef|grep postgrey
It should not run now.

Given that this bug has been reported for some time now, it is amazing it has not been fixed.