[SOLVED] Postfix issues after upgrade

I’m having a bit of trouble with getting email to run after I did an upgrade to Debian Jessie. On all my virtual servers my mail is bouncing with the error:

The error that the other server returned was:
550 5.1.1 example@example.nl: Recipient address rejected: User unknown in virtual alias table

with my main.cf looking like this:

[code]# See /usr/share/postfix/main.cf.dist for a commented, more complete version

Debian specific: Specifying a file name will cause the first

line of that file to be used as the name. The Debian default

is /etc/mailname.

#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

appending .domain is the MUA’s job.

append_dot_mydomain = no

Uncomment the next line to generate “delayed mail” warnings

#delay_warning_time = 4h

readme_directory = no

TLS parameters

smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for

information on enabling SSL in the smtp client.

myhostname = serverlogin.nl
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = $mydomain
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
mailbox_size_limit = 0
recipient_delimiter = +
virtual_alias_maps = hash:/etc/postfix/virtual
sender_bcc_maps = hash:/etc/postfix/bcc
home_mailbox = Maildir/
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
allow_percent_hack = no
smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
[/code]

Anyone have an idea how I can solve this? Thnx in advance!

550 5.1.1 Recipient address rejected: User unknown in virtual alias table;
This is the bounce back message that is received by the sender from our server if the destination email address does not exist.
The same error message is received if the recipient has a mail loop. That is, if the recipient has set a forward to another email address and that email address is forwarded back to the original one. In this case, you need to remove the loop in order to receive the emails.
If there is a forward set for an account, and an email is sent to that account, if for some reason the forwarded email is not sent, the original sender may get the above error.
For example, abc@domain.com if forwarded to abc@dom.com, if a third user xyz@dom2.com emails to abc@domain.com, he may get the above error if the forwarded email is bounced.
Try to add: mydestination = $myhostname, localhost.$mydomain, localhost, your.hostname.com

I am now getting the error:

Host or domain name not found. Name service error
for name=nl type=AAAA: Host found but no data record of requested type

Oddly enough, sending emails is not a problem, just the receiving.

Can you delete one email and create (same) new one, or just make new email (later you can delete this email account). Once done see if you can receive the emails.

I’m still getting the same bounce message unfortunately:
Host or domain name not found. Name service error for name=nl type=AAAA: Host found but no data record of requested type

When I check the DNS records, I do have ipv4 and ipv6 set for that domain by the way

Type=AAAA means there is a problem with IPv6. If you have valid IPv4 try to insert new line “inet_protocols = ipv4”. Oh and dont forget to restart postfix after every change.

I am now getting:
Host or domain name not found. Name service error for name=nl type=A: Host found but no data record of requested type

For me this looks like more as DNS problem then Postfix.
Ok check your domain.com.zone (or hosts) file and see if you have all records in place:

All looking good. NS and MX records are both there as they should

Thank you very much for helping me by the way :slight_smile:

To be sure check your domains with http://mxtoolbox.com and http://www.intodns.com, if there is any problem probably will jump out.

Next idea would be to check your firewall and see if you can connect with port 25 from outside (use telnet to see if you can connect).

Looks like I got it to work. I changed the mydestination in a slightly different way that you suggested:

mydestination = $myhostname localhost.example.com localhost

Thank you for the help :)!

Perfect. Not using Debian (more Centos guy) so i was going with suggestion where usually is the problem but the important thing is that now works. :slight_smile: