Solved - Locked out. bash rescue?

Today I allowed my colleague onto my server to help me tighten the security.
It’s nice. logging in with certs in ssh saves me some time of typing the password.

He also tried to remove the root user out of webmin. Though … He doesn’t know how.
I think he renamed the user.
The unix users he granted root access on webmin also don’t work anymore.
I have a normal ftp user which is still able to login and do some basic stuff (view stats and such). The backup user should also still be able to do the same.

I’m trying to find a config file in the filesystem (su in ssh) to modify so I can either give the ftp user full access to webmin so I can at least pot the backup back Or find the right files to give root back access.

Any help?


Extra info:
in secure log:
15:40:27 public webmin[15518]: Non-existent login as root from

Ok. I’m this far:
/etc/webmin/miniserv.users => root user name was changed. I put it back to root (root:x:0:::::::0:)
in /etc/webmin/root.acl was renamed. Put it back to root (and all other acl’s I could find in that folder and subfolders. Also change the name inside the acl
edit /etc/webmin/webmin.acl => change the name back to root and gife FTP user all rights.
login with ftp user: have access to everything.
but root still doesn’t work.
Unix users I set, also still don’t work.

I ran /usr/libexec/webmin/ /etc/webmin/ root newpass
this made me able again to login to webmin with root.

This also enabled the login with the unix users I set.

Problem solved