[Solved] Dovecot-imapd not installed ... and so not working !

Hi !

I was trying to create a new user on my server but i wasn’t capable of logging nor on Roundcube nor on Squirrelmail, so I try to check some stuffs and I discover that Dovecot wasn’t configure to use IMAP (“network & protocols”). -I hope this is the problem i’m looking for-
So i try to enable IMAP but i’ve got this message :

Fatal: service(imap) access(/usr/lib/dovecot/imap) failed: No such file or directory

OK, so it seems that Dovecot Imap is not installed (I’m pretty sure I used it some times before…). Ok, so I take my terminal and lauch
sudo apt install dovecot-imap
and obtained as an answer :

Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.
L’information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
dovecot-imapd : Dépend: dovecot-core (= 1:2.2.13-12~deb8u4) mais 1:2.2.27-3+deb9u2~bpo8+1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

(Yes, it’s french, but I don’t think it’s a problem. here.)

So I understand I don’t have the good versions installed. So how can I proceed ???

Thanks for your help !



Hmm, I’m not familiar with that particular Dovecot version – it’s possible that the backports repository got enabled and that caused some trouble.

I might start here though, what is the output of this command:

dpkg -l 'dovecot*'

here it is !

Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder | État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements |/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais) ||/ Nom Version Architecture Description +++-==============-============-============-================================= un dovecot-abi-2. (aucune description n'est disponi un dovecot-common (aucune description n'est disponi ii dovecot-core 1:2.2.13-12~ amd64 secure POP3/IMAP server - core fi un dovecot-gssapi (aucune description n'est disponi rc dovecot-imapd 1:2.2.13-12~ amd64 secure POP3/IMAP server - IMAP da un dovecot-ldap (aucune description n'est disponi un dovecot-lmtpd (aucune description n'est disponi un dovecot-lucene (aucune description n'est disponi un dovecot-manage (aucune description n'est disponi un dovecot-mysql (aucune description n'est disponi un dovecot-pgsql (aucune description n'est disponi rc dovecot-pop3d 1:2.2.13-12~ amd64 secure POP3/IMAP server - POP3 da un dovecot-sieve (aucune description n'est disponi un dovecot-solr (aucune description n'est disponi un dovecot-sqlite (aucune description n'est disponi

Well, it’s going well :
I try some magic tricks and after a apt remove dovecot-core dovecot-pop3d dovecot-imapd followed by aptitude install dovecot-core dovecot-imapd dovecot-pop3d, it work !
-but I still can not login on my roundcube webmail (#stayTuned)

we have same problem after update roundcube months ago

did you solved that? ( we are using usermin / webmail for now)