(Solved) Backup Virtual Servers - Old backups not deleted from S3


My Virtualmin domain backups are not being properly deleted from S3 after their delete-after date has passed. I have several weeks of backups present, but I get the following message in the log file:

4 servers backed up successfully, 0 had errors.

Deleting backups from %Y-%m-%d_daily in Amazon S3 bucket my-unique-bucket-backup01 older than 7 days …
… no backups to delete were found

Bucket and Path is set to: my-unique-bucket-backup01/%Y-%m-%d_daily

Delete old backups: Yes, after 7 days

Do strftime-style substitutions enabled

Backup format: One file per server

Create destination directory enabled

Backup level: Full (all files)

I also backup a %Y-%m-%d_weekly backup to the same bucket.

Any ideas? Thanks

Is it possible the %Y-%m-%d_daily (with the “_daily” suffix) is messing things up? Do I need to name the backup simply “%Y-%m-%d” ?

Solved. Apparently the suffix “_daily” was making the script unable to recognize the date string. I am now using separate folders for daily, weekly, monthly, and the folder/filename is set simply to %Y-%m-%d.

1 Like

@Pixelpanther thank you, you just saved me thousands of dollars. I happen to stumble upon our backups that weren’t being deleted and I had -full and -incr appended. I my opinion this is an issue but anyway at least for now there is a workaround.

Everybody check your backups! But, yes, Virtualmin should be loud about something that could be expensive failing (either backups not working or something that would lead to infinite backup data growth).

This topic was automatically closed 14 hours after the last reply. New replies are no longer allowed.