SMTP stopped working on Client and Device

I had my email account setup on my phone and outlook and it won’t send email now. it just stopped working. I have to mention that the logs show.

Feb 14 12:24:50 static2 postfix/smtpd[13525]: connect from unknown[]
Feb 14 12:24:54 static2 postfix/smtpd[13525]: warning: unknown[]: SASL LOGIN authentication failed: authentication failure
Feb 14 12:24:54 static2 postfix/smtpd[13525]: disconnect from unknown[]

BTW I turned off Bind because I use the DNS of my host. I dont know if that is the problem but I turned that off a while back. If that is the problem what do I need to add to my host dns for this to work properly. is already there.

Well, those messages only say that that authentication didn’t work. Do you see any additional errors?

One thing you might try is to restart both Postfix and Saslauthd to see if any errors show up when doing that. You can restart those by running these commands as root:

/etc/init.d/postfix restart /etc/init.d/saslauthd restart

After doing that, do you see any errors?


Nope no errors when restarting

Feb 14 12:52:26 static2 postfix/postfix-script: stopping the Postfix mail system
Feb 14 12:52:26 static2 postfix/master[13400]: terminating on signal 15
Feb 14 12:52:26 static2 postfix/postfix-script: starting the Postfix mail system
Feb 14 12:52:26 static2 postfix/master[15049]: daemon started – version 2.3.3, configuration /etc/postfix

But still keep getting authentication failed please verify your username/password on my device. I have not changed anything and the same credentials work on Userman.

Can someone help?? I can’t get STMP to authenticate. I don’t know why. It just stopped working. I even tried changing my password on usermin but still wont work on device or client. It worked fine forever. I don’t understand.

I don’t know why email has to be so complicated. I didn’t have this issue with sendmail.
After browsing dozens of forum posts, the answer was editing /etc/init.d/saslauthd and adding -r for the FLAGS= so it is FLAGS=-r
And restarting the service. Pretty obnoxious to say the least because I don’t know why that is not default and also it worked for about a month without that there. I’ve been using email style logins the whole time and out of the blue it stopped working. I really like virtualmin but it seems hard to get support.