SMTP starttls on port 587 not working

OS type and version Rocky Linux 9.3
Webmin version 2.105
Usermin version 2.005
Virtualmin version 7.9.0 Pro
Theme version 21.09.5
Package updates All installed packages are up to date

In the Virtualmin Show Email Client Setting it recommends

This fails for me I have to use SSL on port 465 to send email, if I use the above I get timeout straight away no delay unlike normal timeouts. Port 587 is Open.
Is this a recommended incorrect or do I need to enable something in postfix?
If I do this would be a bug.
I found this in postfix

Should this be set to yes

Ok, not sure whats going on, I set to yes and stopped and started Postfix and it started working reload wasn’t enough.
I then set to No and stopped and started postfix and still worked.
So its a mystery what going on, but it working now.

Yes, this should be set to Yes. Not sure about the whole “switched to No but still working after restart” though.

Actually, no, it shouldn’t. Unless I completely misunderstand what the problem is. That option can’t have anything useful to do with it. That’s for relaying mail. Has absolutely nothing to do with receiving mail, or anything to do with other ports…you need to look in Server Processes to configure the submission port (587).

I left it at No, maybe saving of the config in webmin plus stopping and starting postfix fixed something in the background but its start to except port 587.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.