SMTP setup

Hi all,

I’m able to receive email, but, sending fails with “relaying denied IP name lookup failed [].”

As you can see, I’m trying to send from a computer on the dmz part of the lan through the public facing server.

In any case, I don’t want Sendmail to make this check AT ALL regarding client ips. I want to base relaying strictly on user authentication, but this is trickier than I thought it would be - either that or I simply can’t find that one lucky checkbox!

Is there a convenient "click here to ignore client ips and relay any mail that comes from a valid user" button somewhere?

I’d be more than willing to use PostFix, in fact I tried shutting down the sendmail server then starting postfix. But, I always get an “unable to connect to server” from whatever client I try it with… so, seems like Sendmail may be the least problematic.

Tony<br><br>Post edited by: mrwilder, at: 2009/04/24 14:52

So, you’ve just described the default configuration in a Virtualmin system, if you used :wink:

I don’t actually know how to setup SMTP authentication in Sendmail. It’s been years since I’ve managed a sendmail server. Maybe somebody else knows how and will chime in. You’re going to need saslauthd up and running, and you’ll need to tell sendmail to relay when saslauthd authenticates someone. I don’t think it’s possible to make that into a simple button…SMTP authentication is actually quite challenging to setup.

Unfortunately this box has Fedora installed on it. Do you suggest I go download some other distro and rebuild the box? If so, which? AAARGH.

In any case, I used yum install postfix.

If I shut off sendmail and start postfix, it appears to be running in webmin, but, I can’t actually connect to it… so far, I haven’t actually been able to find the page where the listening port is set, but I assume that’s 25.

Any ideas why I might not be able to connect to it - but I CAN connect to sendmail when it’s up?

Hi Tony,

Yeah, it’s been years since I’ve dealt with Sendmail, so I probably won’t be able to help much in getting that working :slight_smile:

If you were using Postfix, what I would do is fire it up – and then look in /var/log/maillog when you launch the daemon, and when the client connects, to see what sort of error is in there.

However, Fedora is troublesome for a server-distro. It’s life cycle is a bit short. Moving to a Virtualmin-supported distro would solve a few problems, including giving you longer support for your server, as well as allowing you to get everything working using the script.

The gets everything setup for you out of the box. If you’re familiar with Fedora, I might suggest CentOS 5 as a server distro. But Debian 5 and Ubuntu 8.04 are good too.

And it is working so well on the other box, which, as far as I can remember, I installed in exactly the same way.

SOOooo, the suggested course of action is exactly this:

1)download the 6 debian CDs

  1. install debian with the server packages (assuming it installs like fedora)

  2. download and install webmin

  3. download virtualmin and run


That about it?

That sounds pretty durn close, but I would drop step #3, it only makes things more difficult than they need to be :slight_smile:

So essentially:

  1. Install your (Virtualmin supported) distro of choice

  2. Download and run script

  3. Profit!

There’s no need to install Webmin, running the handles that, along with nearly everything else.

As far as what distro, that’s up to you – Joe seems to like CentOS and Debian the most, and both work well with Virtualmin.

But once you get your distro installed, running the script on a fresh distro install handles all the legwork for you.

Have a good one!

Fine, I guess I’ll be up all night installing CentOS and giving it another shot if it’s gonna save me some headaches down the road.

Thanks for the input.

Fine, I guess I'll be up all night installing CentOS and giving it another shot if it's gonna save me some headaches down the road.

If it’s taking you all night, you’re doing it wrong. :wink:

You generally only need the first CD for a minimal install; and it should only take 20-30 minutes. will take care of installing the extra stuff over the network using yum, and can be left unattended.

Okay, that’s done.

Still have problems sending mail from a client.

Here’s the maillog error:

Apr 25 00:09:16 ns1 postfix/smtpd[21700]: connect from unknown[]
Apr 25 00:09:16 ns1 postfix/smtpd[21700]: NOQUEUE: reject: RCPT from unknown[]: 554 5.7.1 <>: Relay access denied; from=<> to=<> proto=SMTP helo=<Tonys>
Apr 25 00:09:16 ns1 postfix/smtpd[21700]: disconnect from unknown[]

I’m confused why the internal IP of the client computer is listed, since it’s connecting to a public facing computer, and I’d suspect I would see the router’s address as the client, but, in any case, I’m still getting the relay access denied…

I’ve followed step by step the installation instructions from a blank slate.

Any ideas?


Don’t worry, we’ll get it figured out :slight_smile:

Now we have a common starting point to work from, we know how the system looks and is configured ATM, so that’s good.

Assuming you’ve created that email account in Virtualmin, the most common reason you’d get that is if the client weren’t sending it’s login info when sending the email.

The email client needs to be configured to authenticate outgoing SMTP messages. For example, Outlook is like that – you have to check a box in the settings in order to get it to attempt authentication for outgoing SMTP connections.

There’s a few other possibilities, but let’s see if this does the trick first :slight_smile:

If it doesn’t, do you see any errors in the mail log if you log in over SSH, and type:

/etc/init.d/postfix restart


Well, that worked… hehe…

Thanks all!