SMTP Issue

Hi there.
I have just come to enable email on a server I have been using for a while for websites only.

I have created a new virtual server and enabled email.

I have created the account in outlook, but when I try to connect to the outgoing server to test, it says “The server responded: 421 Cannot connect to SMT”.

SMT isn’t a typo, there is no P on the end…

I have checked maillog and there is no mention of smtp whatsoever.

The incoming server is mentioned in the log, I can see that correctly, but smtp isn’t mentioned at all, but I think it should be as I’m trying to connect to test!

I have installed a SSL Cert against the domain (Lets Encrypt) and set this as the certificate for dovecote and postfix.

I have attemped to connect on ports 25, 465 and 587 but to no avail.

Can anyone suggest things to check?

I’m stumped!!

Oh, and mxtoolbox fails the smtp check as it cannot connect using port 25.

Did you check if the ports are open?

25 looks to be open, but 465 and 587 don’t appear to be, even though i have installed the SSL certificate.

I would have at least expected an entry in maillog wouldn’t you?

Well you should check your iptables or firewalld (depending what are you using).

I think most ISPs has closed the ability to use the default SMTP directly, in Sweden all ISPs has closed the default ports, we had to open up a different port and also set up postfix to use that port.


I’ve disabled the iptables firewall to see if that makes a difference.
Regarding the port being blocked by the ISP, I do have that ruled out.

Is there a way to completely reset the postfix and possibly the dovecot modules? Maybe re-install just those?

I have a feeling something is really amiss!

Dovecote service looks as though it is running from the Server Status section, but when I view in Bootup and Shutdown, it says it isn’t Running Now.

This is a similar issue with Postfix as well. It says it is running in Server Status on the front webmin screen, but Bootup and Shutdown says it isn’t…

What could cause that?

I’d be happy to set someone up a test email account to try it out…

But I also think reinstalling postfix and dovecote might help? If this is possible?