SMTP Error: Could not authenticate

I kept getting this error “SMTP Error: Could not authenticate.” while trying to connect with my Email. (I’m using FluentSMTP – WordPress Mail SMTP)

The SMTP username and password are 100% right, and the port 465 is working! Why could not authenticate ?!

Please I need your help, I tried for hours to solve this issue but I didn’t go far !


What does your mail.log file show?

1 Like

Thanks for reply,

These are the lines that appear after FAIL

May 12 22:50:53 vmiXXX postfix/smtpd[XXX]: connect from[XXX]

May 12 22:50:55 vmiXXX postfix/smtpd[XXX]: warning:[XXX]: SASL LOGIN authentication failed: authentication failure

May 12 22:50:55 vmiXXX postfix/smtpd[XXX]: disconnect from[XXX] ehlo=1 auth=0/1 quit=1 commands=2/3

I just replaced some number + my IP with XXX

If you can help me to solve this, I will really appreciate it ! I tried a lot before posting this issue here …

Seems like your SASL plugin most probably isn’t configured correctly. You should check your postfix and and make sure SASL authentication is properly set up.

1 Like


And how to configure my SASL plugin correctly ?

Here is my file
May 12 10:58 PM - Codeshare

Here is my file
May 12 11:02 PM - Codeshare

What’s wrong ?! I didn’t touch these files at all …

@bomtack check your ports if you hosting from home/residential isp and apply common sense. Just have look at the config - its there with click of the mouse. Virtualmin provide excellent access to this problem.

1 Like

Thanks, What config, where exactly should ,I look ?!

Debug log:

The username & pass are correct !

No help :frowning: ?

I know I already said this but your problem is most probably caused by a postfix/sasl misconfiguration. You’ll have to manually go through your configuration files to further pinpoint the cause of the authentication failure (and fix it).

1 Like

This solves the problem

=> Roundcube SMTP error authentication failed on SASL auth failure [#68527] | Virtualmin

After 3 days of trying different suggestions, that one command line solved the issue !


Glad you figured it out Bob. Cheers!

1 Like

What OS and version are you using? I don’t think any supported OS should have Postfix running in a chroot, by default…so, I’m not sure how you got there. But, if it does happen automatically on some distro, I’d want to know about it (and maybe fix it).

I’m using Cent OS 8 …

CentOS 8 definitely does not setup Postfix to run in a chroot by default. So, it had to have been changed (by you or someone else). So…for the future, don’t do that, and you won’t have this problem. :wink:


Thanks for advice :slightly_smiling_face:

I am pretty sure I didn’t change it + No one else have access, only me …


Then it was changed in the image your host used, and it wasn’t a “fresh” install.

The other solution to this problem would be to switch all of your postfix processes back to not being in a chroot (in /etc/postfix/ chroot is often believed to be a security feature…but, it mostly isn’t, and it makes management more complicated/confusing especially for new users.


This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.