Single Archive Virtual Server Backup doesn't backup/restore FTP Users

Can anyone think of a reason that a single archive backup of a Virtual Server won’t create/re-create FTP users when restored?

I am doing single archive because I don’t want to include the /home directory because of space issues (so I can do a “new” style backup).


  • Acorp

In theory, any of the backup types should be able to restore users associated with your Virtual Server.

Of course, it’s always wise to test your backup procedures before relying on them :slight_smile:

I do something similar though – I actually do the new style backups, doing one file per domain, but don’t include /home in the archive files.

I then use rsync to backup the data from /home, which is far more efficient than sticking all that data into the tar archives and copying it off each day.


I also use rsync to back up /home…but when I try to do a “new format” backup without /home, it tells me that the home directory is required to do a new style backup:

A new format backup can only be done when the home directory is included

And when I do a single archive file, everything “appears” to back up correctly, but my FTP users don’t get restored.

Am I missing something?


  • Acorp

Oh, you know what, you’re right :slight_smile:

I ended up needing to go with the “old style” backups in order to make that work.

I’m curious if using old style backups resolves the issue you’re seeing… however, be it old style or single archive file – it shouldn’t allow you to have a feature selected to backup (“Mail/FTP users and mail aliases” in your case) that doesn’t work.

So, I’d label this as a bug :slight_smile: My suggestion would be to file a bug report using the Support link above.


Thanks for the reply. I tried again today, and it works…hmmm, hate it when that happens!

I started with a single domain, used the one archive file backup, restored it to a different server, and the FTP users were there. Tried another one, no problems, FTP users were recreated. Backed up all of my domains (26) at once in one archive, restored them, no problem.

Now I don’t know if I was just having a mind lapse yesterday and doing something wrong, or if there is/was something going on with the backup. The worst is now I’m just not sure I can depend on the backups. Argh.

Guess I’ll keep playing with it, and see if I can get to where I can consistently reproduce an error - or a good backup/restore.