Setting up a nameserver

OS type and version RockyLinux 8.7
Virtualmin version 7.5


Having a problem configuring personal nameserver for virtualmin. I am sure I am missing a step somewhere that is obvious, but I just don’t get it. All the guides I’ve found online, I have tried to follow but clearly am missing something somewhere.

Here is what I have so far
A domain that will be used as a nameserver, lets call it I have changed all the DNS records at the registrar to point to my IP, let’s say it’s
I have a second domain that I would like to host on my server, let’s call it mydomain . com
I have gone into the registrar for that domain and have changed the name servers to ns1 . myns . com and ns2 . myns . com
What do I do from this point on. I have a brand new virtualmin install on a server. Outward IP is the machine hostname is ns1 . myns . com

From what I understood I must first go to Webmin-> BIND DNS Server and create a master zone. There are already a few entries in there: 0, Root zone, 0000::1,, localhost, localhost.localdomain. Do I leave these alone?
Do I create a new master zone called ns1 . myns . com ?

If anyone could point me to some step by step instructions, or provide them to me, would be very much appreciated.

Thank you in advance!


P.S. spaces between . in domain names are for posting limitation reasons

As far as I know you do not touch Webmin to configure your name server on Virtualmin.
Please read the documentation.
This FAQ “How do I setup nameservers for my server?” explains
Alot of VM users say they use the same IP for ns1 and ns2

Yes, I’ve been trying to make send of that guide. So I add my nameserver domain to virtualmin add the 2 ns records to dns for that domain and that is all that is needed for the name server to work?

The most important part of the whole thing is registering your name servers with your registrar. Most people make the mistake of just entering their name servers at their registrar without ever actually registering them, so they never work.

That’s why I tell most people that don’t understand nameserver setup to just use Cloudflare. It takes 10 minutes and you’re done. I’ve told people here that three times in the last several weeks and all three of them have done it and thanked me.

OK so I think I get it now, I need the registrar to setup GLUE records for me, correct?

Yep, you do that at your registrar as it says in the document.
"In order to use your Virtualmin server as a DNS server, it needs to be setup so that names like and can be input as a domain’s nameservers.

For that to work – you first have to go to the domain name registrar for, and register your server as a nameserver. It’s usually as simple as inputting two or more names (such as and, and the IP addresses that are associated with them."

1 Like

Thank you, I assumed it was a bit more straightforward then it actually was!

Hey, so I got the registrar to setup GLUE records. How do I check that they have been setup/propagated? Which test can I run?

Maybe this

So both nameservers resolve to correct ip.

I’ve added the cname and a records for the domain in virtualmin as stated in most tutorials. Added the ns records to domain templates.

But now after adding a domain that is using my nameservers, that doesn’t seem to work.

What should I be checking/testing to find the potential source of the problem?

I use external DNS service so I may not be as knowledgeable. But please screenshot what you have done as you giving very little detail. Not sure why you need a cname. You need 2 A record for the name servers.

What registrar do you use as I normal setup my own, I don’t wait for my registrar support to do it for me.

Ok never mind. Turns out port 53 wasn’t open.

For anyone else in the future, make sure you have udp and tcp port 53 open

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.