Setting the default virtual server for reverse dns AND virtualmin port 10000 access

Ok, I have 3 virtual servers on the same IP (,, and They all work fine. I access Virtualmin/Webmin via and all is great. I then decided two days ago to set my reverse dns through my VPS manager (not virtualmin). I pointed it at I have confirmed with my VPS host (Linode) that the reverse dns is in fact resolving to However, now no longer works. So I tried, which did work a couple of days ago, now it does not work. So, I decided to try and low and behold it went to I asked my VPS host (Linode) about this and they said that the reverse dns only works to resolve back the IP address to a domain name, but it won’t necessarily take you to that domain if you use the IP. I was told this had to be a setting somewhere in Virtualmin/Webmin that when I use the IP address, Webmin is handing off my request to domain2 instead of domain1. So while having the conversation with the tech, I decided to check and it worked. I got right to my Virtualmin login.

How do I set it so that works again and for that matter? Also how do I set it so that when I use the IP as the URL, I get to domain1 instead of domain2.

I can tell you that domain2 is listed in the virtual server’s list 1st and domain1 is last, but I assumed it was listing them alphabetically (domain2 starts with “c” and domain1 starts with “s”)

Hmm, Webmin/Virtualmin should work just fine when accessing it via any domain name or IP address – it shouldn’t be redirecting to a different domain, nor should the reverse DNS matter.

When you access port 10000, are you certain that you’re using “https” rather than just “http”?


Yes, I am using https.

I don’t think it is a coincidence that when I use the IP it takes me to domain2 and domain2 is the only one I can get to access virtualmin. I just don’t see anywhere that domain2 is set as some sort of default.

One thing you could do is check System Settings -> Virtualmin Config -> Server Settings – I’m curious what “Virtualmin URL for use in email messages” is set to.


It is selected for “work out automatically”

The 10000 is working at home for all 3 domains, but not at work for of my domains…only one of them is accessible at work. Any thoughts???