Setting default website directory

Is there a simple way to have a users website created under /var/www/${DOM} instead of /home/${HOME}?

If so, how and where is this set please?

Many thanks

The easiest location to change this is in the System:Users and Groups module configuration.

But, I wouldn’t particularly recommend it.

Why do you want to put home directories in /var/www?

I have spent far too much time trying to get fcgid working - no luck !!

The entire Internet has a major lack in documentation in setting up cgi wrapper/fcgid.

I am getting the usual docroot error.

I just tried recompiling httpd which i did with docroot set but it installs in some obscure directory.

I am using CentOS 5 and have rpmforge, kbsingh etc repos at hand.

Followed all of the instructions, uninstalled/re-installed webmin, virtualmin, httpd, perl, php you name it.

I would really appreciate, as I am sure would others, a simple tutorial on setting up fcgid - as this is an important stage in my services plan.

Many many thanks for such a great product, I am a Pro subscriber and love it !!

Look forward to hearing from you soon


If I cant change docroot then i wanted to try changing the virtualhost directories into the docroot.

I am getting the usual docroot error.

I don’t know what the “usual” docroot error is. :wink:

I am using CentOS 5 and have rpmforge, kbsingh etc repos at hand.

Why not use ours? We provide an Apache package for CentOS that has docroot set to /home.$arch

Grab the virtualmin-release package and install it.

Or, just use our automated install script, which gets everything right out of the box (though it doesn’t setup fcgi wrappers for you, in the GPL version).

Note that rpmforge packages (particularly clamav) are known to be incompatible with ours (which are based on Fedora Extras, generally).

i ran the install script i think.

should i set protect to 1 on the virtualmin repo ?


Excellent !!

That did the trick.

Thankyou Joe

although virtualmin is designed to use the /home directory, it seems to me that you can change this in the server template
virtualmin-system settings-server template-click default template-navigate to Apache website and change the DocumentRoot and other settings involving ${HOME}

but don’t blame me if it breaks things.
Better have Jamie or Joe advice you on this!