set_time_limit seems to have no effect

despite tuning the max exec time, i have this message:
mod_fcgid: read data timeout in 31 seconds

i am running a webscrape through a proxy, all is going fine, until this messgae happens.
the safe mode is disabled, and i have this instruction at the beginning of the script
why is the script still stalling at 30 seconds? thank you for your answer.

Ok the solution is at the Apache server level i found the solution on this page
sorry but it is in french
so you must edit the apache config file and set the variable IPCCommTimeout to a longer duration


You may want to go into Server Configuration -> Website Options for this particular domain, and in that screen, set “Maximum PHP script run time” to a higher value.