Server freeze/Internet lost upon restart after clean installation

Operating system: Ubuntu
OS version: 18.04

Hello,
I am getting a bit desperate here. I have been trying to install Virtualmin on a server the last couple of days. First I did it, added servers and everything, and when I tried to update the kernel from within the interface, the server tried to restart, but never came back to life. As I tried to open it in some safety backup mode, I could see that it started after reboot, but it was completely disconnected from the Internet.

First, I thought it had to do with the kernel update, but today I reset the server completely, and installed Virtualmin on a pure installation, and I just typed reboot after instaling, and exactly the same thing happened. In other words, it wasn’t because of the kernel, but something happens as I install Virtualmin, that makes the Internet connection disappear (something with the network settings) making me unable to communicate with the net completely after installing.

Anyone has any clue where to start to fix this problem?

Hi,

What is the output of:

ls -lsa /etc/netplan

… and

cat /etc/netplan/*

Hello,
here you can see the screenshot of what I see with the two commands…

answer1

Addresses line is incorrect. Remove manually all those HASH(), leaving only IP addresses and apply netplan:

netplan apply

Thanks, that actually seems to work! :))

Yes, but I wonder how come you ended up with having those in-place? What hosting provider is it? Did they have Webmin preinstalled?

Hello,
it is hetzner.com, and I just got an empty ubuntu installation, follow the virtualmin installation protocol, and it by default added those lines.

Thank you for the help, by the way - so it worked!