Sendmail & Postfix problem

Hello dear people,

Please believe, I am Googling the internet about one week and I did not find any possible solutions for my issue with SendMail & Postfix. I am pretty new on Unix, Linux, Webmin & Virtualmin. Operating system of my VPS is CentOS 5. Webmin and Virtualmin (Free Version) is installed. As I require a mail server, I decided to add SendMail. I could configure SendMail enough but there was a problem, I can mention it as below that I can send e-mail messages to anywhere through ‘User Mailboxes’ but not Outlook Express. Authentication works correctly. The problem is that SendMail tries to relay target email domain and not my server. It is what I have found out. Anyway, I could not find any possible way to resolve it. I decided to switch to Postfix. But post on Postfix thing’s gone wore. I was unable to receive emails and no emails were sent. For incoming I get "rejected error" and for outgoing I get "relay access denied". When I try SSH and telnet localhost 25, I get "relay access denied" error.

I am really confused. Please let me know what should I do.

Please help me.


Whenever you try to send or receive a message, what error(s) show up in the error log (/var/log/maillog)?

Dear Andreychek,

Thank you for your reply.

Unfortunately I am out and cannot get access to server to paste the maillog. But I can explain the issue some more.

About SendMail:

  1. Authentication OK.
  2. Receiving e-mail from anywhere OK.
  3. Sending e-mails via User Mailboxes or PHP mail function OK. (sends e-mail to anywhere)
  4. Sending e-mail via Local PC and Outlook express FAIL. (sends e-mails only to hosts accept Relay)

I think when I try to send an email via Local PC and Outlook Express for example from to, the SendMail tries to set instead of relay=localhost. For some servers like Gmail it is possible but for many other not. It is just my idea, I am a NEWBIE.

About Postfix:

  1. Authentication OK. (happened after arranging permissions)
  2. Receiving e-mail from anywhere FAIL. No way to receive. (even localdomain user cannot send e-mail to other localdomain user)
  3. Sending e-mails FAIL. No way to send.

Currently I am working on Postfix and SendMail is stopped. I will post the mail logs as soon as possible.


Please help!

I have switched to SendMail, because there was a large log file I decided to clear the maillog (/var/log/maillog). Webmin (View Logfile) acts interesting. When there is no maillog file or maillog file is empty View Logfile displays previous records but when I enter a line inside ,aillog file it shows new records. My problem is that SendMail does not update the log file. I have tried to restart syslog service but no thing changed. Please help me!!!


i think you are better off using postfix, it is the default in virtualmin.
you’ll have to switch mailserver through the commandline, but i do not remember the command.
It is here in the forum somewhere though.

Also if you do not find a satisfying solution in this forum I advice to submit a support ticket in the bug tracker.

Yeah, as Ronald said, while Virtualmin does support Sendmail – Postfix may be a bit easier to get running, and more people around these parts are familiar Postfix and can help with any odd issues that arise :slight_smile:

I’m not sure why Sendmail wouldn’t be logging things – I guess I’d verify that there isn’t a different log in /var/log somewhere that contains it’s logs (though I’m not sure why that might have changed).

Also, perhaps /var/log/messages contains information on what the problem is. Try restarting Sendmail, and see if anything odd shows up in that messages log.

Thank you for replies

I have switched to Postfix again, I have changed the mail server from SendMail to Postfix via command line. I used below command:

[code:1]alternatives --config mta[/code:1]

Currently the sending problem FIXED. I can send e-mail through web and outlook express. Authentication works as well to not allow Open Relay. But still maillog does not update regularly and also all incoming messages rejected.

Please help me.

This is error:

Technical details of permanent failure: Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 554 554 5.7.1 <[]>: Client host rejected: Access denied (state 14).

Please advise me.


Yeah, email programs should definitely be making log entries in the log files :slight_smile:

When you restart Postfix (/etc/init.d/postfix restart), do you see any errors listed in /var/log/messages?

Actually I do not see anything related to Postfix. But this log file updates regularly. I can see my failure login attempts while checking authentication (saslauthd server). Also what is your idea about No Receiving emails? Also there is some notable in User Email, a strange e-mail, it is as below (Subject : DON’T DELETE THIS MESSAGE – FOLDER INTERNAL DATA):
Message Comment :

This text is part of the internal format of your mail folder, and is not a real message. It is created automatically by the mail system software. If deleted, important folder data will be lost, and it will be re-created with the data reset to initial values.

How do you think about a Reboot? May it be helpful?


Well, one issue may rely on the other, unfortunately.

I’d really need to see the email logs in order to determine why you aren’t able to receive messages.

I wouldn’t be concerned about the email containing the “DON’T DELETE THIS MESSAGE” email – while I haven’t seen those since the day I used pine as an email client, that are harmless and not likely a symptom of the issue here.

So, to be clear, nothing is logging to /var/log/maillog? And, nothing of interest is in /var/log/messages relating to Postfix.

Do you happen to see any other logs in the /var/log directory with Postfix related information in them?

Do you have enough disk space? You can verify that with "df -h".

Those are just some thoughts, let me know if that doesn’t help.

There is enough disk space,

/dev/simfs 6.0G 1014M 5.1G 17% /

Actually there is no log related to postfix, I also checked inside of other log files and no thing found. I think I got to reboot the server, maybe it helps some. How do you think?


Ok, so you should have plenty of space.

You could always try rebooting if you want, though I’m never a big fan of that as a solution. It skips the step of learning what is wrong, and invites the problem to occur again :slight_smile:

I’m interested in logging into your system to take a look at the problem myself, if you don’t mind.

What version of Virtualmin are you using, and is it Pro or GPL?

I am using Virtualmin GPL.

Alright, if you’re interesting in having me take a look, you can email login details for root SSH access to

I’m just not sure what would cause the symptoms you’re seeing, so I’d need to poke around myself to get a better idea.

It is okay, but do you need Supervisor root access?

Yes, to be able to troubleshoot the problem, I’d need either root access, or access to a user level account that has full sudo privileges.

I have sent required information, the e-mail subject is "here is the data".

Please check it.

Sorry, mistyped, the subject is "here is the info.".

Dear andreychek,

please confirm back to me that you have received the e-mail. Thank you

Altera and I went over some things via email.

The problem with syslog is that the conf file was setup to send mail.none to maillog, rather than mail.*. I corrected that.

Unfortunately, there appear to be a few problems with the Postfix setup.

Switching back and forth between Sendmail and Postfix may have caused some problems – first, Virtualmin will use whatever mail program you tell it to, but it doesn’t transfer email users back and forth. So none of your email users are setup in Postfix.

Amongst other things :slight_smile:

If this isn’t yet a live system, my recommendation is to uninstall Virtualmin (by running the script with the -u option), then go through the Virtualmin installation again, allow it to configure Postfix, and then not change that :slight_smile:

At that point, when you setup your Virtual Servers and email users, it should in theory work fine.