sending email on another smtp port

My ISP blocked smtp 25 for domestic home user and I found this post
to enable alternative ports.

As mentioned in the post, I uncomment submission and smtps in and restarted postfix.

However I am still not able to send email. there are authentication error.

I went back to read and found there are some options under of these two lines

submission inet n - n - - smtpd # -o smtpd_tls_security_level=encrypt # -o smtpd_sasl_auth_enable=yes # -o smtpd_client_restrictions=permit_sasl_authenticated,reject # -o milter_macro_daemon_name=ORIGINATING smtps inet n - n - - smtpd # -o smtpd_tls_wrappermode=yes # -o smtpd_sasl_auth_enable=yes # -o smtpd_client_restrictions=permit_sasl_authenticated,reject # -o milter_macro_daemon_name=ORIGINATING

should I enable one of the options ?

You’d want to uncomment those lines beginning with “-o” as well, as those are parameters for submission and smtps.

After that, make sure you restart Postfix.

If it still doesn’t work though, what errors are you seeing in your mail logs? Those are in /var/log/maillog or /var/log/mail.log.


I had a similar issue at my home until I sprung for business internet. I tried switching my SMTP port but it still did not work. I had to use my ISP’s SMTP server as a smart server for postfix. Usually their SMTP server is something like: I guess ISP’s can pick up that you are sending emails even on another port. I never had a problem forwarding my outgoing mail through their SMTP server. It acted as if it was coming from my SMTP server.

For incoming mail, at my router, I had public port 52525 pointed to local port 25 on my postfix server. I used’s mail port redirector service ($50 a year) to redirect any mail to port 52525.

That $50 a year also includes spam checking and if your server is down, they will hold the mail for awhile.

I hope this helps.

I uncomment -o smtpd_sasl_auth_enable=yes
to use sasl for authentication

I checked maillog and shown authentication failed

Aug 4 05:56:28 host2 postfix/smtpd[25968]: warning:[]: SASL LOGIN authentication failed: authentication failure

I could able to logon on webmail with same user name and password