Selecting Apache SSL website enabled? automatically triggers LetsEncryprt

Ubuntu 18.04 LTS

Hi,

Whenever I select the “Apache SSL website enabled” option when editing a site it automatically triggers LetsEncrypt for a default set of subdomains. These default subdomains are a static list and if not all of them are currently configured in DNS (my DNS is external) the process fails. For example, I do not use a subdomain called “admin” so when the process fails I have to go into the LetsEncrypt option to manually set the subdomains I need for the domain

I would prefer that the LetsEncrypt process would NOT automatically trigger.

Is there any way around this, either of of the following outcomes would work:

  1. Allow me to set the default subdomains created when the SSL enabled option is ticked
  2. Only enable SSL for the site and allow me to manually run the LetsEncrypt option (preferred)

Cheers

i dont make a habit of replying to my own posts but after posting this I realised that I had never been into the DNS Records option in Virtualmin as all my DNS records are set up externally (to ensure that if this server goes down, those with email hosted externally, my preference for all the sites I host, are still functional).

I found the list of subdomains in the DNS Records that LetsEncrypt is using. Seems pretty obvious place to look once I found it.

Anyway, problem solved!

1 Like