Script Installer Upgrade fails


I have some MediaWiki installations and wanted to upgrade them by using the script installer upgrade feature.

When running the scripts I receive

Database connection failed : DBI connect failed : Access denied for user 'user'@'localhost' (using password: YES) 1397

I searched for resolutions to this problem, but nothing really pointed into the right direction. The password is obviously set correctly as the wiki is working like charm. The user privileges encompass everything and the database access for user is granted for localhost.

Any help is highly appreciated.

I would really lice to upgrade my MediaWiki installations … am I really the only person having this problem? Any ideas how to fix this? Would a complete reinstallation fix that issue?

help … :’(

… but I really need to get my installations upgraded - how can I fix this?


Well, let’s start here – are you able to perform a new install of mediawiki into an alternate sub-directory?

That’s just a temporary installation, you can delete it afterwards – but it’ll show whether the correct username and password are being used by Virtualmin for that domain.



first of all. thank you very much for your help!

I created a sub server, tried to make a plain installation, but got the same error: Database connection failed : DBI connect failed : Access denied for user ‘domain.tld’@‘localhost’ (using password: YES) 1397.

So I tried the following to get this fixed:

  • Reset the domain password
  • Installation with “Initial login for script”: “Same username and password as domain”
  • Installation with “Initial login for script”: Username: root and root’s password
  • Granted all permissions for domain user domain.tld in MySQL
  • Reset password for domain user domain.tld in MySQL to domain password

Unfortunately none of the attempts made the install script run, I get the same error every time.

I know how to upgrade MediaWiki on the command line, but I really want to make it work in Virtualmin, as I am too lazy … :wink:



I wanted to mention that as a Virtualmin Pro customer, if you don’t receive a response in the Forums, you are always welcome to open a support ticket using the Support link above.

You’ll always get a response there, and we work very hard to solve every problem!

It sounds like the database password that Virtualmin has gotten out of sync though.

What happens if you go into “Edit Databases” for that particular domain, and then go into Passwords.

There, try resetting the database password for this particular Virtual Server.

After that, are you then able to upgrade Mediawiki?



sorry for the late reply! I followed your instructions and resetting the password under “Edit Databases” to the one specified in LocalSettings.php did the trick.

I will try the “Support” option next time … but hopefully this information will help others with the same problem. :slight_smile:

Thank you!