script cannot be installed, as it requires PHP4


CentOs5 Virtualmin Pro/Unlimited

Trying to install the "Help Center Live" At this point I am beginning to need it…

I tried ‘yum install php4’ and it broke the php-mysql module in php5 …
So I don’t wont like to go mucking around, I break things…

So what do I do? …

I see I am not the only one to find proftp problems. starting on 1/27 . vsftpd is working for now, when they fix proftp, I will go back…

Don Peek

would you not rather have a helpdesk that works under php5 ? like Crafty Syntax Live Help 2.14.5

It is what I use and am very pleased with.

That looks like a nice system. I picked this one because it is in the scripts and it had the most stars for the help desk. The real problem isn’t getting a help desk to use, but if this script need php4, I am sure others do also. So I need to find out how to turn on an off the php selection for the websites, but I don’t see that except when I had php4 install and it broke php5. OR I need find out how to bypass the checking.

But thanks for the lead on the software… When I get some time I will be checking it out …


actually cslh works fine under php5 and you could put it under the script install module yourself.,script_installers/
php4 shouldn’t be used.

cslh is one of the best free helpdesk software imo and I wonder why it isn’t in the default setup.

Let talk phpNuke… To install it, I need php4, I even have one site on the old system was running nuke and now with the new control panel will not run. I tried to install a new one and you guessed it. will not install without php4 …

Sometimes you can "correct" this install problem by looking at the "info.xml" file in the directory where the program is located. This file may have another name than "info" but almost always has the "xml" extension. Look for a line that says something like:

<VERSION name="PHP" value="4.1.0" rel="ge" />

The "rel" is the key here. Requires "ge" ( greater than or equal to )
Packages are different in the way this requirement is stated but you should be able to find it.