Scheduled Backups not displaying destination field


This is probably something really simple but I just can’t see it. I am trying to set up a incremental backup. When I set up the parameters using the Backup Virtual Servers option I can select where the backup should go, but I can’t schedule the backup.

If I go to Scheduled backups I have no option to choose a location.

What am I doing wrong?

I think I figured it out but it is a bit awkward.
If I select another option such as FTP and the fields for that get displayed, If I then go back and select Local File/Dir the field for the directory and file name is displayed.

You actually have to make a different selection first. Just selecting the Local file or directory option will not display the field.

I would have thought that the field should be displayed with the default setting of Local file or directory and not require the display to change in order to be come visible.

Another item I can’t seem to be able to access is a checkbox to allow me to select Backup Format - ‘One file per server, in new format’
According to the help info there should be 3 choices, I only see 2

Am I misunderstanding this?

And while I am asking these questions, is there a simple way to create a scheduled backup (full and incremental) of a specific directory rather than a whole server? I am wanting to backup only a nextcloud data directory which stores all the actual data files.

Figured it out.

It does a complete copy (no incremental from what I can see) Don’t know how I missed it previously.
I assume the checkbox ‘In TAR format’ is OS dependant?

Backup & Restore -> Scheduled Backups -> Schedule and reporting

Thanks Stegan,
I use that for backing up my virtual servers but sometimes I just want a specific directory backed up. I can use an rsync script and cron to do this but I thought that webmin/Virtualmin would have something built in. The Filesystem backup in Webmin works fine but it only appears to be able to create a full backup. With Nextcloud data the data directory alone can get pretty big so an incremental backup can be useful. I am using the virtual server backup with a weekly full and daily incremental to do that task right now. I have not yet tested how long it takes to back up several hundred GBs yet using the filesystem backup, compared to a full server backup. That will be my next test.
Its really the data that I am most concerned about as its pretty easy to throw up a new server as long as I have all the original image files stored safely.
I think I might have tried that filesystem backup before but only got configuration files so I figured it wouldn’t do what I wanted or else it was some other webmin backup? Not sure, as there are so many options spread around in the menus which make it difficult to figure out what each does, and if I get distracted I basically have to start from scratch again. :grimacing:

1 Like

I have exactly this issue on 22 Feb 2013

22 Feb 2013

10 years ago?
Are you referring to the missing field?
Did you try my work around?

You have to do that in Webmin under the System / Filesystem Backup command. The Virtualmin / Backup Virtual Server command assumes you’re going to back up the entire virtual server, so the options are limited to basically that: the entire Virtual Server, just the settings, just the files, etc.

Thank you.
I don’t know how I missed that one. Time to get my eyes checked.
That was what I was looking for.

Not only do I need my eyes check but I think I need to get my brain checked. Just looked at my previous posts and realized that I actually checked that dialog previously and stated that I figured it out.
However I think originally when I scanned that dialog I only saw the restore buttons at the bottom. On my screen the button to actually create the backup doesn’t really look like a button as it is attached to the field on its right. It highlights when you mouse over but at a quick glance I might have missed that and thought that the dialog was only for restores. I should know better since that is the standard for all the dialogs.

1 Like