S3 minio server backup woes

I’m trying to setup a home s3 server for backup of my virtual servers on another host (lon.mortgages4all.co.uk).
I’m getting told my details fail verification and would really appreciate some help.

I have minio running behind nginx, both via docker on ubuntu core, and it appears to work.
id: 7Q781M1UTLHVO6Y3TC10
key: nkz2mESTsqtv1D2tyfkdTy47O2S72R549eYbeD5c.
The pc updates a dynamic dns (no-ip, but am tempted to setup my own) address of smakrouter.hopto.org
It also has cnames setup as s3.home.mortgages4all.co.uk (plus wildcard) which points to home.mortgages4all.co.uk which points back to smakrouter.hopto.org

No matter what url I use, I end up failing verification in cmdline and error listing buckets (same as cmdline), I even tried running s3cmd from the virtualmin host which works and I can connect and transfer files using Cyberduck, so my dns and ssl are fine.

How can I turn on debug mode and have a look at whats going on. Also where is the debug log spat out as it were :slight_smile:

This is the cmdline I’m trying (also tried without bucket in hostname but included as folder in path):
virtualmin backup-domain --domain atouchofbeautybristol.co.uk --all-features --dest s3://7Q781M1UTLHVO6Y3TC10:nkz2mESTsqtv1D2tyfkdTy47O2S72R549eYbeD5c@test-bucket.s3.home.mortgages4all.co.uk/atouchofbeautybristol.co.uk.tar.gz

[I’ll change the keys as soon as it’s working properly, please feel free to play around with the server and attempt to access it or ideally backup to it (about 1.5Mbytes/s)]

Linked support issue: https://www.virtualmin.com/node/68076

For anyone still attempting to look at this, server was offline for a few hours so my apologies.
Changed secret/keys with no joy, excuse the user/pass terminology…
user: tyeth
pass: password123

Operating system Ubuntu Linux 18.04.2
Webmin version 1.932 Usermin version 1.780
Virtualmin version 6.08 Cloudmin version 9.4 Pro