Roundcube password change

SYSTEM INFORMATION
OS type and version REQUIRED
Webmin version REQUIRED
Virtualmin version REQUIRED
Related packages SUGGESTED

Dear sirs,

Problem: Roundcube password not saving… meaning, users cannot change their roundcube password.

I have read through several tutorials online, but none seem to work.

Password plugin has been enabled

Error log:

[22-Dec-2022 07:20:26 +0000]: DB Error: [1064] You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘%c WHERE username=‘name.surnname-domainname.com’’ at line 1 (SQL Query: UPDATE mailbox SET password=%c WHERE username=‘name.surnname-domainname.com’) in /home/domainname/public_html/program/lib/Roundcube/rcube_db.php on line 564 (POST /?_task=settings&_action=plugin.password-save)


question: why is an account name shown as name.surnname-domainname dotcom instead of name.surname at domainname dotcom

regards
Tokunbo

1 Like

Update:

I referenced this tutorial: Installing Roundcube Email Client on Virtualmin and Configuring the Password Plugin | by Rafael Parungao | Medium

Here is my error log:

[22-Dec-2022 13:53:00 +0000]: DB Error: [1064] You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘%c, ‘ta-domainname.com’)’ at line 1 (SQL Query: SELECT update_passwd(%c, ‘ta-domainname.com’)) in /home/domainname/public_html/program/lib/Roundcube/rcube_db.php on line 564 (POST /?_task=settings&_action=plugin.password-save)
[22-Dec-2022 13:58:16 +0000]: PHP Error: Password plugin: Unable to execute /home/domainname/public_html/plugins/password/helpers/chgvirtualminpasswdArray
(
[0] => Array
(
[0] => No user named ta-domainname.com was found in the server domainname.com
[1] =>
[2] => Modifies a mail, FTP or database user in a Virtualmin domain.
[3] =>
[4] => virtualmin modify-user --domain domain.name
[5] => --user username
[6] => [–pass “new-password” | --passfile password-file]
[7] => [–disable | --enable]
[8] => [–real real-name]
[9] => [–quota quota-in-blocks]
[10] => [–add-mysql database]
[11] => [–remove-mysql database]
[12] => [–enable-email]
[13] => [–disable-email]
[14] => [–add-email address]
[15] => [–remove-email address]
[16] => [–recovery address@offsite.domain | --no-recovery]
[17] => [–newuser new-username]
[18] => [–enable-ftp]
[19] => [–disable-ftp]
[20] => [–add-group group]*
[21] => [–del-group group]*
[22] => [–send-update-email]
[23] => [–no-check-spam | --check-spam]
[24] => [–add-forward address]*
[25] => [–del-forward address]*
[26] => [–local | --no-local]
[27] => [–autoreply “messsage” | --no-autoreply]
[28] => [–autoreply-start time | --no-autoreply-start]
[29] => [–autoreply-end time | --no-autoreply-end]
[30] => [–autoreply-period secs | --no-autoreply-period]
)

[1] => 'domainname.com'
[2] => 'ta-domainname.com'
[3] => 'passwordhere'

)
in /home/domainname/public_html/plugins/password/drivers/virtualmin.php on line 70 (POST /?_task=settings&_action=plugin.password-save)

It seems the password plugin is looking for ta@domainname.com, instead it finds ta-domainname.com

Note: the user account name is ta@domainname.com

Please help point me in the right direction of what to do.
regards
Tokunbo

1 Like

It’s not yet supported by RoundCube. It was discussed on this post, and hopefully will be supported in the future.

1 Like

Thanks for the revert.

Tokunbo

1 Like