Roundcube not accessible

I have just installed Virtualmin on a VPS running Ubuntu 10.04 LTS.

I couldn’t find any instructions on how to install Roundcube, so I tried clicking on Webmin > System > Software Packages. I then searched for Roundcube in the APT search facility on that page and allowed it to install the three relevant packages it found.

When installing roundcube-core, it said error failed because it was unable to determine database type. Then a few minutes later when using apt-get at the commandline to install midnight commander, apt-get told me that roundcube had been installed and needed to be configured. It asked me a few questions and then informed me that Roundcube had been successfully installed.

However, you wouldn’t know it since I still can’t access it via or anything remotely like it.

What do I still need to do please? I would like to be able to access it from every hosted domain by visiting

Many thanks in advance.

Applications installed via apt tend not to work well – the easier way is to install an application within a particular domain, and have your other domains redirect to it.

To do that, you’d pick a domain, and manually install RoundCube into it.

You can find instructions on installing Roundcube here at the Roundcube website:

And then, you can read about setting up Roundcube as the default email program in Virtualmin here in the section named “How can I use Roundcube as the default webmail program instead of Usermin”:

Ok. Thanks. I’ll follow those guides. My next question is how can I remove or undo what I’ve done? Do I just do apt-get remove roundcube, etc…?


Well, I’m not sure what all you’ve done thus far – but yeah, just running an “apt-get remove roundcube” would be a good start.


I’ve now installed Roundcube, but the installer page tells me,

Roundcube may need to write/save files into these directories
temp/: NOT OK(not writeable for the webserver)
logs/: NOT OK(not writeable for the webserver)

Use chmod or chown to grant write privileges to the webserver.

It looks like the webserver user is www-data, so I ran:

chown -R www-data:www-data /temp


chown -R www-data:www-data /logs

but the installer is still complaining that it can’t write to those directories.

What have I done wrong please?


It sounds like you may be using mod_php for that particular domain, rather than FCGID or CGI (FCGID is the default).

I’m not sure the two chown commands you ran above would do what you expect – however, switching back to FCGI or CGI should actually solve that for you.

You can make that switch in Server Configuration -> Website Options, and there you can change the PHP Execution Mode.

If you change it to FCGID, does the Roundcube installer finish?


Eric, you’re a genius! Thank you very much!

I checked the Server Config, but it was already set as FCGID, but seeing that alerted me to the fact that roundcube is not being run as www-data, but as the actuall user for that account (snowweb), so I ran the commands:

chown -R snowweb:snowweb /temp


chown -R snowweb:snowweb /logs

(if the above appears in oversized type again - it wasn’t me!)

and then refreshed the Roundcube (stage 3) Installer page (which is the ‘test config’ stage) and the red marked items had changed to green and it seems happy.

I also managed to goto the login page, which seems to display ok. I can’t test t any further just yet as I need to migrate a domain over to do that and also need to install some email accounts, which I’ll do after I’ve finished adding stuff (like phpmyadmin and a legacy copy of the Squirrel).

Thanks Eric.