Roundcube Install Errors

Operating system CentOS Linux 7.2.1511
Webmin version 1.782
Theme version Authentic Theme 17.62.
Kernel and CPU Linux 2.6.32-042stab093.4 on x86_64
Processor information Intel® Xeon® CPU E5-2630 v2 @ 2.60GHz, 4 cores

I am having difficulty installing Roudcube.

I have domain :
I have created a subdomain ( to install Roundcube to, and all mail requests will be redirected to. ie:

When I go to the virtual server --> install scripts , Choose RoundCube and “Install Options”, I choose the database created for domain when I created the subdomain. This database is named “webmail_roundcube”. I’ve also tried existing database for that domain (webmail).

I then choose “install sub-directory under” --> “At Top Level”

I click “Install Now” and get the following:

Found in cache …

Configuring webserver PHP settings …
… already done.

Applying web server configuration …
… done

Now installing RoundCube version 1.1.4-complete …

Database connection failed : DBI connect failed : Access denied for user 'admin'@'localhost' (using password: YES) 1397.

… failed! See the error message above for the reason why.

Applying web server configuration …
… done

I have tried resetting the mysql password via the Virtualmin interface for that user, to no avail.
I can ssh to the server , connect to MySql as that admin user, and create/drop/alter tables from the mysql command line .

Any suggestions as to what I am doing wrong ?

thank you in advance for any help.

I tried installing Roundcube from command line, and it works somewhat. … However, I believe virtualmin must set config values differently, as I cannot log in with “”. I must log in as “username.domain”.


I have the same issue in Ubuntu 14.04 one month now and I can’t figure it out.

I have tried to reinstall the devcot but it doesn’t work.

Any suggestion or any solution to this issue?