Roundcube change password issue - Error: Could not save new password.


I have installed Roundcube v1.3.3 in Virtualmin version 5.05 and activated “password” plugin by editing “/config/”


// List of active plugins (in plugins/ directory)
$config[‘plugins’] = array(

Then rename “/plugins/password/” to “/plugins/password/” and I can see Password reset field in “Roundcube > Settings > Password”.

But when I am trying to change password then it shows error: “Error: Could not save new password.”
It does check the current password so it means that it is able to connect to the database.

I also tried to run following commands from “/plugins/password/helpers” directory:

gcc -o chgvirtualminpasswd chgvirtualminpasswd.c
chown root: chgvirtualminpasswd
strip chgvirtualminpasswd
chmod 4550 chgvirtualminpasswd


$config[‘password_driver’] = ‘virtualmin’;

But it is still showing the same error. Can anyone please help?


After further investigation, I found that “chgvirtualminpasswd” is not executing:

Password plugin: Unable to execute public_html/plugins/password/helpers/chgvirtualminpasswd

I tried all possibilities to fix it permission but it is still not working:

chown root. plugins/password/helpers/chgvirtualminpasswd
chown root: plugins/password/helpers/chgvirtualminpasswd
chown : plugins/password/helpers/chgvirtualminpasswd
chmod 0777 plugins/password/helpers/chgvirtualminpasswd

I tried to execute the file from using php exec() and it shows error “/usr/sbin/virtualmin must be run as root

echo exec(‘plugins/password/helpers/chgvirtualminpasswd’);


Have you checked the “error_log” to see if there is a specific issue the script is running into?

After a long discussion with Roundcube support, I could fix this bug: