Roundcube at fault: lost fastcgi socket for domain - how best to fix?

Ok I swear it was around here somewhere.

I had a site working well under the domain running wordpress under nginx; however after testing email functionality it seems to be only a 502.

So I started to do some investigating – I went hunting down it’s socket as listed in it’s config and within the /var/php-nginx/ directory I see but not it’s 13931429941503.socket/socket counterpart as I do all the other domains.

I’ve tried /etc/init.d/php-fcgi-gadbooks-com start but that changes nothing, no socket is created.

I even tried rebooting the entire VPS but still nothing.

How can I get the necessary (and once available) 13931429941503.socket/socket to bedgin? Would it be ‘better’ to set up fcgi as a port rather than socket and how would I do that?

Also afte reading I’m adding the results of

So here’s mine:

root@blastii:/etc/init.d# ps auxwww | grep gadbooks gadbooks 1372 0.0 0.1 23196 3796 ? S 12:30 0:00 /usr/bin/perl /usr/bin/ /usr/bin/php5-cgi -b /var/php-nginx/13931429941503.sock/socket gadbooks 2840 0.0 0.1 23204 3868 pts/1 R 12:48 0:00 /usr/bin/perl /usr/bin/ /usr/bin/php5-cgi -b /var/php-nginx/13931429941503.sock/socket root 3651 0.0 0.0 6468 928 pts/1 S+ 12:56 0:00 grep --color=auto gadbooks

I’ve tested by going through the steps again - somehow roundcube has screwed up the nginx / php-fpm set up… would love to use roundcube but it seems to not be an option now.