Root password not set while installing Virtualmin in CentOs7

Operating system: CentOS
OS version: 7
Virtualmin did not ask for any password while I installed it in CentOS 7, I am unable to login to the VPS. I tried resetting the password by /usr/libexec/webmin/changepass.pl /etc/webmin root PASSWORD , but it returned me an error,

Can't locate ./acl/md5-lib.pl in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl usr/lib64/perl5/ usr/share/perl5 .) at /usr/libexec/webmin/changepass.pl line6.

I tried changing the line 6 in /usr/share/webmin/changepass.pl
to require “/usr/libexec/webmin/acl/md5-lib.pl”;
I changed the root password succesfully. But still am unable to login to webmin.

It isn’t expected to set the root password.

You should already know your root or sudo-capable username and password. And, if you don’t you should set it using the passwd command on your system (not the Webmin changepass.pl command, though I guess you could, Webmin users and passwords are a special case that doesn’t really make sense for most people).

I just reinstalled Virtualmin, It got alright, I was able to change the password.