Rocky-Linux is alive!

hello all -

I am trying to install VirtualMin on Rocky-Linux. is there some “easy” way to alter the install script to recognize Rocky-Linux like it normally recognizes Centos-8?

i considered doing a manual install: Installation Guides | Virtualmin but this warningdiscouraged me:

Installation of Virtualmin and related packages manually. This method is time-consuming, and requires a high level of technical experience. This is not recommended , except in cases where the automated installation is inappropriate or impossible.

YES i understand Rocky-Linux is just in a release-candidate mode, but i wanted to test out the Webmin/Virtualmin installation process ahead of time if possible.

Operating system:
OS version:

The installer is pretty close to working on Rocky Linux. I don’t know details, but I’m pretty sure @Ilia has done installations on both Rocky and Alma. There may need to be updates to install.sh or slib.sh, I’m not sure. Maybe he can fill in the details of what’s needed.

If you search the forum for discussions of Alma Linux, Rocky will likely be a very similar story.

Edit: To be clear, you don’t need a manual install on Rocky. It is CentOS compatible. The only problems are with detection and maybe some minor issues. You should not do a manual installation on Rocky. The automated installer should still be used, it just may need minor tweaks to work.

Yes, currently the installer is pretty ready. We however haven’t added Virtualmin 7 repos yet, this is why you would need to manually edit vm_version string for now, before using this beta version of the installer.

You are welcome to give it a try and share your experience.

1 Like
wget http://software.virtualmin.com/gpl/scripts/install.sh ;
chmod --verbose  700   ./install.sh ;
./install.sh ;    

hi - i tried changing vm_version=6 to vm_version=7 and 'vm_version=8` & running with same results.

next i tried downloading and running: https://raw.githubusercontent.com/virtualmin/virtualmin-install/master/virtualmin-install.sh

that certainly got me a lot farther along. the script ended with:

Dependencies resolved.
Nothing to do.
Complete!
: Success.
Spin pid is: 15127
Username/Password Authentication Failed.
Downloading virtualmin-release-latest.noarch.rpm: [2021-05-18 12:40:50 EDT] [ERROR] Failed with error: 6
[2021-05-18 12:40:50 EDT] [ERROR] Something went wrong. Exiting.
[2021-05-18 12:40:50 EDT] [ERROR] The last few log entries were:

i am trying again on a fresh install. perhaps there were traces of the first several attempts, but i am just guessing.

EDIT: identical results using fresh install - using both ./install.sh as well as
./virtualmin-install.sh. :persevere:

No, that’s not what Ilia is saying.

If you download the git version of that script that Ilia linked (different from what is on software.virtualmin.com), and change vm_version to 6, it will probably work.

2 Likes

Rocky Linux installed seamlessly on a VirtualBox once the change was made.

THANK YOU once again to Ilia and Joe Cooper once again for their patience with me.

next up: installing it on google-cloud vm.

EDIT:

[9/23] Configuring Net                                                  ▒▒▒▒▒▒▒Error: Module virtual-server does not exist
Error
-----
Module virtual-server does not exist
-----
▣▣▣ Cleaning up

[WARNING] The following errors occurred during installation:

  ◉ Postinstall configuration returned an error.


# tail   -20  virtualmin-install.log
[2021/05/18 13:36:21] [INFO] - Code: 0 Result: Warning: ALREADY_ENABLED: 20000:tcp
success
[2021/05/18 13:36:21] [INFO] - Code: 0 Result: Warning: ALREADY_ENABLED: '1025-65535:tcp' already in 'public'
success
[2021/05/18 13:36:21] [INFO] - Code: 0 Result: Warning: ALREADY_ENABLED: 1025-65535:tcp
success
[2021/05/18 13:36:22] [INFO] - Code: 0 Result: Warning: ALREADY_ENABLED: 'domain:udp' already in 'public'
success
[2021/05/18 13:36:22] [INFO] - Code: 0 Result: success
[2021/05/18 13:36:22] [INFO] - Code: 0 Result: Warning: ZONE_ALREADY_SET: public
success
[2021/05/18 13:36:22] [INFO] - Succeeded
[2021/05/18 13:36:22] [INFO] - Configuring MySQL
[2021/05/18 13:36:22] [INFO] - Succeeded
[2021/05/18 13:36:22] [INFO] - Configuring NTP
[2021/05/18 13:36:23] [INFO] - Succeeded
[2021/05/18 13:36:23] [INFO] - Configuring Net
[2021/05/18 13:36:23] [WARN] - Detected DHCP-configured network. This probably isn't ideal.
[2021-05-18 13:36:23 EDT] [DEBUG] Cleaning up temporary files in /tmp/.virtualmin-34784.
[2021-05-18 13:36:23 EDT] [WARNING] The following errors occurred during installation:

however, a fresh install worked fine - so i am declaring this one a victory.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.