rh-php56 is not being recognized by virtualmin

I have the latest Virtualmin installed on CentOS 7 which has php version 5.4 and apache 2.4 installed by default. I have successfully installed a second php version, php55, from the rhscl repo and it is recognized and working great. BUT now I installed rh-php56 from the same repo and when I recheck the configuration, Virtualmin doesn’t seem to recognize it. What am I doing wrong?

Here are the commands I ran followed by the Virtualmin Re-Check Configuration:

yum install rh-php56 yum install rh-php56-php-mysqlnd rh-php56-php-gd rh-php56-php-xmlrpc rh-php56-php-bcmath rh-php56-php-mbstring rh-php56-php-pecl-xdebug rh-php56-php-xdebug-debuginfo rh-php56-php-pspell rh-php56-php-soap rh-php56-php-intl rh-php56-php-pecl-jsonc-debuginfo rh-php56-php-pecl-xdebu-debuginfo rh-php56-php-recode scl enable rh-php56 bash

Just for reference the additional repos used are:

rhscl-php55-epel-7-x86_64 rhscl-rh-php56-epel-7-x86_64


Virtualmin should support PHP version 5.6.

What is the full path to the PHP 5.6 binary?

However, I’m actually not sure if Virtualmin can support more than 2 PHP versions… I’ve never tried that before.

Does it work if you just have PHP 5.4 and 5.6 on there?


What code checks for software collection php versions installed on centos 7?

On my system

CentOS Linux release 7.1.1503 (Core)

After installing software collections php 5.6

scl -l




If I make a symbolic link between /opt/rh/rh-php56 and /opt/rh/php56
the virtualmin recheck picks up php56.

What other changes needed for proper operation?


That symbolic link is all you need – and Virtualmin will handle that correctly in the next release.


Look forward to next release.

On virtualmin 4.1.8 gpl

Services shows

PHP 5 Configuration

PHP 5.4 Configuration

PHP 5.5 Configuration

There is no

PHP 5.6 Configuration listed on left hand menu

Need to make additional changes?

phpinfo shows php 5.6.5 available with /home/{domain}/etc/php5.6.5/php.ini