Restoring from *.INFO file does not work.

I get this error, when attempting to restore from a *.info file instead of the full 1GB+ backup file. I was trying to avoid having to d/l the backup file twice (why won’t you just keep the backup you originally downloaded and then restore from there when the options are chosen???).

Restore failed : The specified source is not a Virtualmin backup : Not a valid tar or tar.gz file

I think it’s a bug or I am doing something wrong.

Restoring from an FTP btw, I have 3 files per backup, the extension-less tar/gz file (1GB+), a *.dom file and an *.info file.


You can’t actually restore from a .info file. A .info and the .dom file are just a files containing metadata about the actual backup, which is the .tar.gz file.

To perform a restore, point it at the .tar.gz file and you should be good to go!


I know how to do restores. The problem is that restoring downloads the HUGE backup file TWICE. First download is when you hit “show me what can be restored.” Second download is when you select the servers you want restored and hit the equivalent of “continue.” It downloads the same file again all over.

Why not keep the already downloaded file and just restore off of that I don’t know, but this is what I found in the Virtualmin changelog:

When Virtualmin sends a backup to an SSH or FTP destination, it now also creates a .info file that contains meta-infomation about each backup. When restoring only this file needs to be downloaded to list the contents of a backup, which avoids the need to download the complete backup twice.


I tried using the *.DOM file, same error as the *.info. This effectively makes both of those files useless and the restore process bugged.

I just performed a similar restore a few hours ago, I pointed the restore script at the directory, and not a specific file, it found the files it’s self.

Okay, I will try that. I don’t think I saw that in documentation.

Well, I thought it would be possible to do “/backup/dir/backup-name-%time%/backup-name” with the “create destination directory” checkbox ticked off, but I just get an error saying that destination directory does not exist.

I tried just using “/backup/dir/backup-name-%time%/” but that merely removes the trailing slash and puts the backup triplet (gz, dom and info) of files in the /backup/dir/, which is how I had it setup before.

No matter which way I turn, I cannot get this .info/.dom restoration going. How do you save each backup in a separate folder so that I can point to that folder as described? I can’t even test this yet as is.


We use a format like:


What this does is it creates backups like:

/backup/directory/2014-02-16/ /backup/directory/2014-02-16/ /backup/directory/2014-02-16/



Keep in mind “%time%” doesn’t exist. You’d need to use a valid substitution string for this to work, and also make sure you’ve enabled “Do strftime-style time substitutions on file or directory name” otherwise it won’t work.

*** By clicking on the text “Do strftime-style time substitutions on file or directory name” you can get a list of valid substitution strings. ***

Best Regards, Peter Knowles TPN Solutions

Phone: 604-229-0715 (new)
Skype: tpnsupport

Sorry I was not clear enough. I did not remember how the strftime-style time substitutions actually looked, so I just used “%time%” as a place holder. This is what I have been using:


Can I not have the servername-virtualmin in the folder’s name before the timestamp?

I should mention that I backup all virtual servers in 1 file. Could that be the issue as to why I could not get the folder creation to work? It looks like you have 1 file set (gz/dom/info) per server/domain. Does pointing to the directory with the one file/server setup let you have the same restoration options as just having 1 bulk file?


The substitutions should work regardless of format used.

I prefer the “one file per server” as it allows for restoring on a domain basis if needed, but that merely a preference for us.

Best Regards, Peter Knowles TPN Solutions

Phone: 604-229-0715 (new)
Skype: tpnsupport

You can have the server name in the filename, like this


If your server was named webserver the file would look like this “webserver-virtualmin-2014-02-16”