Restore Website on Rocky Linux 9

Rocky Linux 9 with Virtualmin Beta installer

Hi I restored some sites without issues but with one I simply don’t get it to work.

During the restore I see this:
Starting FCGIwrap server …
… failed : /var/fcgiwrap/165700227721078.sock/socket
later this:
Checking restored PHP execution mode …
… mode FCGId cannot be used, switching to FPM.
Updating PHP FPM configuration …
… failed

And than this
WARNING - The following scripts used PHP versions that are not available :
007.datateam.center - WordPress - Version 7.4

The site simply gave me an error 503 than and in the logs of apache I see:
[Tue Sep 06 11:50:02.556256 2022] [proxy:error] [pid 22131:tid 22172] (13)Permission denied: AH02454: FCGI: attempt to connect to Unix domain socket /var/php-fpm/165700227721078.sock (*) failed
[Tue Sep 06 11:50:02.556271 2022] [proxy_fcgi:error] [pid 22131:tid 22172] [client 87.118.116.40:55632] AH01079: failed to make connection to backend: httpd-UDS

Any Ideas? I continue to investigate but maybe you have already seen that error before

Addition:
When I deactivate under PHP Options the script execution mode it works.
Reenabling it breaks it down again

By the way mod_fcgid is also installed installed but in the options I just have FPM now or disabled

Addition 2:
I found out that the sock file have the wrong user assigned.
Deleted them and restarte php-fpm and they are recreated again with the wrong user.
for this site he uses halt:lp but why??

thanks

For anyone I figured out why it didn’t work
The problem is that I used a user named 007 for that site and than he didn’t understand
changing it with a letter in front to jb007 and manually adapting the php fpm file solved it.

But still don’t know why fcgid isn’t available anymore?

Hello,

We do not have suexec compiled with /home directory in Apache, and we no longer ship custom Apache builds. Please use FPM mode, as this is the best and recommended choice to run PHP scripts.

@Jamie, is there a way we could be friendlier in familiar case scenarios?

1 Like

Hi

Thanks
I have no problem running it with fpm
Was just suprised that it wasn’t visible anymore
Now I know

It’s my first Rocky Linux Install :slight_smile:

Would just be nicer if when restoring the error messages wouldn’t appear…
Simply a notice at the end would be enough or so…

For that number only user I think not many user are doing that lol - I renamed it within webin (couldn’t find an option on my virtualmin part)
But the logs weren’t usefull - As another Wordpress site worked from restore I knew it couldn’t be a problem from that side and so I played around

By the way I restored my cloud based on Nextcloud and the install script tells me that a new version is available
But starting that I get a message that he couldn’t find the PHP version needed??
Maybe due to that the base install was under PHP 7.x and now I’m on 8.1.x

1 Like

For renaming I now found that over the renaming domain area I can also just rename a user… Thought I only could rename the domain…

Here the message for the script installer upgrade regarding PHP:

Upgrading Nextcloud to version 24.0.4 …
… failed dependencies : No PHP version could be found for this virtual server

What this migrated virtual server has set on PHP Options page? Does it have PHP mode set?

I think it’s simplier with an image:

It’s the correct version of PHP - also on my old server before the migration I was also on PHP 8.1.x since several weeks. I tested now and also on my old server I get this message.
Before with PHP 7.x it worked well
It’s not a big issue as I can upgrade manually but maybe there is a fix for it somehow?

Thanks

Is it also normal that under Rocky Linux there is no Webalizer anymore to install?

No, as it was simply removed from OS packages. We would suggest using AWStats as it’s far more superior to Webalizer.

2 Likes

I’m surprised that it was possible to create a numeric user, because we normally block it to solve exactly this kind of issue. How was this 007 user created exactly?

Great - So i don’t need to continue searching for it :slight_smile:
thanks

Hi
I simply did what I always do:
Click on create virtual server and entered all the data
Didn’t get any warning (must be within the last 2-3 month - Just as Test site at the moment) that a user with just numbers may cause a problem

How was this 007 user created exactly?

If he told us, he’d have to kill us.

1 Like

@Jamie, nothing stops the user from putting custom administration name as 007, right?

1 Like

That’s a bug … I’ll check in a fix for it.

1 Like

Any ideas yet about that issue?

That should be fixed with Virtualmin 7.2.

1 Like