Restore fails with tar error

Hello all,

using Webmin Version 1.500, Virtualmin Version 3.76.gpl on Debian 4.0 etch,
I try to restore a Virtualmin-Backup from
Webmin Version 1.500, Virtualmin Version 3.76.gpl on Debian 5.0 lenny.

But, I get the following error:

Starting restore of 1 domains from local file /home/falko/ …

Extracting backup archive file …
… extraction of /home/falko/ failed!

/bin/tar: Pattern matching characters used in file names. Please,
use --wildcards to enable pattern matching, or --no-wildcards to
suppress this warning.

.backup/*: Not found in archive

/bin/tar: Error exit delayed from previous errors

Backup does not contain virtual server information for missing domain

… failed! See the progress output above for the reason why.

Is there anything I could do to get this server imported from Backup?

Thanx in advance,



Well, from the output above, it sounds as if there may be a problem with the backup archive.

If you were to untar that backup manually, do you get any errors? And, do you see a directory called .backup with various config files in it?


Thanx for your quick answer.

Yes, after doing

myserver:/home/falko# mkdir restore_test
myserver:/home/falko# cd restore_test/
myserver:/home/falko/restore_test# tar xzf …/

I have the following:

myserver:/home/falko/restore_test# ls -as -1 insgesamt 72 4 awstats 4 .awstats-htpasswd 4 .backup 4 .bash_history 4 cgi-bin 4 etc 4 fcgi-bin 4 homes 4 logs 4 public_html 4 .usermin 12 .viminfo

myserver:/home/falko/restore_test# ls -as -1 .backup/
4 mydomain.de_logrotate
4 mydomain.de_mysql
380 mydomain.de_mysql_mydomain.gz
2112 mydomain.de_mysql_mydomain_yaml_405.gz
0 mydomain.de_unix
4 mydomain.de_virtualmin
64 mydomain.de_virtualmin-awstats
4 mydomain.de_virtualmin-dav
4 mydomain.de_virtualmin_plan
8 mydomain.de_virtualmin_template
4 mydomain.de_web
1112 mydomain.de_web_alog
4 mydomain.de_web_elog
20 mydomain.de_webmin

Is there a way to give the “–wildcards” option to the tar cmd when doing restore?

Best regards,

It sounds like you may be running into a bug of some kind.

What I’d recommend is to file a Support request, as Jamie may need to tweak some things so that the parameter you’re seeing above is used, as it’s possible some tar defaults have changed.



just to get around for now, I’ve searched for “.backup/*” and changed line 1093 in from

# Home format as in ZIP file $homeformat{$f} = $f; $extract = ".backup/*"; to # Home format as in ZIP file $homeformat{$f} = $f; $extract = ".backup/";

–> then the restore worked flawlessly
(only apache2 wasn’t running any more afterwards caused by “Invalid command ‘FCGIWrapper’”, which hasn’t been noticed by virtualmin during restore, but this is another thing - virtualmin should IMHO at least call “apache2ctl configtest” before restarting apache).

tar --version shows:
tar (GNU tar) 1.16 Copyright © 2006 Free Software Foundation, Inc.
tar/stable uptodate 1.16-2etch1

I don’t know if this is a bug or just a behaviour of my installation, but I’ve filed a bug report at

Thanx for you support!