Restore failed : The specified source does not contain any domains, or is not a Virtualmin backup

I have a site, I backed up only its files resulting in a 2.57GB file:



I immediately attempted to restore that file and Virtualmin says:

Mercifully I am not relying on this (I found out about this by attempting to move the site from one box to another, not because I need to restore the backup). What is the issue here and is there a work around besides “Don’t use the Virtualmin backups for the site’s files”?

OS type and version Ubuntu 22.04
Webmin version 2.105

If you click select all it will work as you expect.

Well it might restore everything, but I only want to restore the files. This way, for example overwrites the stats, the database, the logs, settings, etc… What if I am in a situation where the files on my site have become mangled, but the database has days of updates (sales information for example), and I want the current logs to try to find out what mangled the site’s files (not the ones in the backup), and I have changed the user’s and ftp passwords because I think one of them might be actively doing the site-mangling?

Basically what if I don’t want all this stuff? It’s as though the checkboxes are not useful if what you want is your site’s folder structure (I tried both ways, using a backup with only the files and telling it to restore everything, and a backup with everything and telling it to only restore the files… similar result… well a backup with everything but with only the site’s files selected gets me “None of the selected features are used by any of the servers in this backup, and thus the restore cannot proceed.”).

Inconveniently you can’t just unzip the resulting .gz file and ftp its contents in as that file does not contain the folder structure but a series of folders like this:


all with little bits and pieces.

As I said, I am discovering this and don’t need the backup, but I could see this being something of a catastrophe for someone otherwise.

On the restore iption in virtualmin just choose what feautures you want to restore e.g files

That’s the thing I took a screen shot of not working unless I misunderstand you.

When I uncompress a domain backup it looks like this. It is only what is in the home folder for that domain. If you want to backup other files you can backup filesystems or archive from the finder but you will only get whatever files you select.

The image you have posted looks like the contents of a mail directory which is pretty useless unless that is what you need.

Whatever I want backups for I save on the server. I choose a directory in home. You can set up scheduled backups and auto deletion if you like. Then I use the file manager to download to my local computer to save or look through as needed. Ftp or rsynk would work the same but I find the filemaniger is too easy.

I ment at this page

If my backup contains everything, that will overwrite everything (logs, database changes, user passwords, etc). If my backup is a backup of only the site’s files I get:

“None of the selected features are used by any of the servers in this backup, and thus the restore cannot proceed.”

How ? you can selectivly restore what you want. On one site i have to restore the database only from time to time so i just tick the database in the restore options and oddly enough only the database(s) are restored and nothing else

It’s not mail folders, each one has a “.” folder inside it, and then another folder inside of that with a little snippet of the site’s contents (and there are over 500 such numbered folders):

This specifically regards backups downloaded via the web interface. (I regard backups stored on the server as not backups at all, and anyway not relevant for the project since what I was trying to use this for was move site files-only from one virtualmin to another.) It also specifically regards a site whose downloaded .gz file is 2.57GB.

You gave me the idea to upload the downloaded files first and then try the restore as being from a local file, but I get the same result, a backup with only the sites files give me:

And if I upload the file that has everything but specify to only restore the files like this:

I get this:


Maybe you are doing something different to decompress your .gz file? My example was from 7zip on a Windows machine. You seem to be doing it inline somehow?

Why don’t you use the virtualmin tranfer domain option as this is virtualmin to virtualmin ?

Yes it works for databases, but not for files-only, at least not if the zip of those files is 2.57GB. This:

gets me this:

On a backup that only contains the files that is 2.57GB (as originally reported and shown in screen shots). That same selection gets me this:

As later shown.

I know exactly what you are pointing me at. I’m saying that it doesn’t actually work when you choose to restore just the site’s files, at least now for sites with 2.57GB of files.

If you have such a site you might want to consider backing up its files another way… though theoretically you could manually backup everything except the files, then restore your full backup of everything (to get the files, overwrite the logs, passwords, database, etc) then restore the manual backup you just took of everything except the files in order to get back any changes you made to any of those things… which I think I’ll try now for completeness.

This happened because you didn’t include the Virtual server password, description, and other details (very first) option. The backup only included home directories.

If you want it to be restorable in Virtualmin, you need to always select the first option.

@Jamie, is this even an option we want to have? Why don’t we always include Virtual server password, description, and other details?

From one production server to another, as poorly as this backup works for a large site, no way. Either way that sounds like it would want to transfer everything and I only want to transfer the site’s files.

No, you just need to tick the Virtual server password, description, and other details option if you want this backup to be restorable in Virtualmin!

No need too … this interested me so i just did a file restore of 2.5gb (approx) with no problems, however the restore did run for about 45 mins, and i confirm the restore worked fine. I noticed in one of your posts that you were using 7zip. I would stick to tar.gz 7zip doesn’t support file permissons so you may find that the restore when extracted has different permissions to what you expect

I think i get this now you want to copy the domain’s public_html contents and not restore the domain on a different server, if so you would not use virtualmin backups to do it as pointed out virtualmin requires the user to be present. Why not compress the files you want using file manger then download that. Then you could upload that file to the other server then extract that file whereeve you want using file manager

So just fyi if I check those with - Only those selected below - it errors and doesn’t make a file.

OK if I select Backup all features I can just select one server in Servers to save without moving it to the arrow over box and it works.

If I select Only those selected below and arrow the selected server in the box on the right then it works without error.

When you select specific domain in the accordion above, you need to double click on the domain name or use arrows to actually select it, so it moves to the right-side select and becomes actually selected.

This is it of course, so thank you.

Not for nothing but that seems mis-labeled, especially since you cannot download a backup of just the sites files and then restore those files. Without a note to that effect (or a checkbox with something like “Needed to restore to virtualmin”) what I end up with seemed useless to me. Eventually I found that I could use tar at the Windows command line to unzip the tar inside the gz and that would extract the structure rightly, but if this was 3:00am and I’d been counting on this doing either thing that it seems like it “just would” (be restorable / be a zip of the folder structure usaable with the standard Windows tool), I would have been having having a panic attack.