"Reset" a virtual server to clean config

Operating system: Linux/Debian 10
OS version:

Dear Community,
I humbly ask for help as I’d probably deserve lashing for what I did :grinning:

  • I’m using a Dell R240 server, which is at home so far, behind my ISP router.
  • I’ve set up a virtual server to host a Nextcloud instance. Both http and https websites are activated.
  • Nextcloud requires some settings to grant a green dot to the system.
  • Part of the settings were configured through Virtualmin and part through direct editing of the Apache config file (hence the lashing :wink:).
  • I’ve created a self-signed certificate to protect the https website.
  • I’ve set up a proxy (Nginx Proxy Manager) on another machine and created the proper DNS entry to route nc.mydomain.com → my router → proxy → Virtualmin.

I now have 2 different issues but they’re probably related to each other:

  1. The redirection worked for a while but I now stumble on a weird issue as neither the https://nc.mydomain.com, nor the LAN_IP:8080 reaches the login page. I only get a HTTP502 redirection error.
  2. When it worked, the browser complained about the self-signed certificate, although the proxy has been properly supplied with a Let’sEncrypt certificate.

Question 1: is there any way to ‘clean’ the virtual server configuration without being forced to reinstall the whole stuff (NC users, shared folders, plugins, all has already been installed and configured, etc.)?

Question 2: how can I get rid of the self-signed certificate? Maybe I could just use the LE certificate in the proxy for the construction phase and point to the http website, until the server goes in production mode…

Thanks in advance for any help you could provide to a dummy! :grinning_face_with_smiling_eyes:

Hi all,

Coming back lately on my issue… I tried today a really “rustic” fix, by creating another virtual server, with almost the same name, copy/pasting the website + SSL website configuration into the corrupt one and it worked! Didn’t expect it was possible as I thought I had to do all config through Virtualmin…

Hope this could help someone though…

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.